Conan exiles isle of siptah update 3.0 armor pet invisible bug

Game mode: *[ Select one: (Online official)
Type of issue: *[ Select one: Crash | Bug]
Server type: [ Select one: [ PvE ]
Region: [ America]
Hardware: [ xbox series x ]


Bug Description: just downloaded update 3.0 and my armor amd pets are invisible the actual character is missing parts of body where amor should be, shows armor numbers as if im wearing it but not showing up and my feral dog is invisible with green health bar.

A clear and concise description of what the bug is.


Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. download update 3.0
  2. connect to isle of siptah on america pve server
  3. jump back into my game
  4. armor and pets invisible
  5. (etc)
3 Likes

my armor just showed up on my charcter if anything changes will keep posted.

Hello there Exiledbarbarian1, welcome to our forums!

Thank you for your report, if anything changes in the meantime please let us know so we can process it :slight_smile:

Hello, I‘m playing on official pve conflict server 7022 and we have the problem with invisible armor, pets, enemies, structures.

Some armor works, some pets are visible, parts of structures are visible

Seems to be mostly dlc armor that when wearing makes your body invisible, helmets make your char have very short hair by the looks. Elephants only show eyes but every now and then they pop up and disappear again.

Some players already abusing this by walking around with just their head visible and trying to pvp. Not really fun fighting someone who I can barely see. Same for invisible enemies, not fun getting stabbed by a floating sword xD

Could you please take a look at that? Thank you very much.

btw, Update is very good besides that bug, good work

1 Like

I have the same problem.

Having the same issues. I am on an xbox one elite with a SSD upgrade. Crashing frequently with texture rendering issues with npc’s, buildings and armor. I have set my video setting to performance with no success. I have checked my server setting but no fix. All this came with the update.

So I figured out the crashing issue and its related to the processing power of you xbox. You no longer can play Conan on a Xbox One unit you will have to upgrafe your console to continue to play. Rendering textures are still an issue but few sometimes fill and others never do, even hours (6+) of play. Agian server settings and game settings are fine.

Hello there everyone!

Thank you for taking the time to reach out to us!

We are aware of a situation occurring where some assets were coming up invisible and we have released a new patch in the meantime.

You can find the patch notes for this patch here.

As for the crashing, does this happen on all servers/game modes regardless?

Please let us know if the situation persists after patching the game.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.