Delving Pride of Aesir gives Pride of Aesir recipe again (returned bug)

Game mode: Online official | Single-player
Type of issue: Bug
Server type: PvE
Region: EU
Mods?: No
Edition: Steam

Bug Description:

Tried to delve Pride of Aesir armor piece in Siptah Official EU PVE server #6423, got another Pride of Aesir recipe not Frost Giant Garb recipe as expected outcome.
Reproducing in Single Player gave the same result (please see screenshot):

It is returned bug as i understand from topic: Delving for Frost Giant Armor with Pride of Aesir only produces Pride armor

Installed Mods: No

Steps to Reproduce:

  1. Put pride of Aesir armor piece and 50+ Eldarium bars in Delving Bench
  2. Delve armor
  3. Receive Recipe of Pride of Aesir as a result of delving
  4. Repeat process in SP and observe the same result.

It’s a chance to drop either Pride of Aesir or Frost Giant Garb, not guaranteed. :wink: I wish you better luck on your next roll. :grin:

Yeah, my char is exile from EL who travelled to Siptah to learn Siptah recipes (i learned PoA recipe in EL) and it was surprise for me, didn’t know it^^ :smiley: but i got the point. Thank You for answer!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.