Game still doesnt launch

Game mode: Online official
Type of issue: Bug
Server type : PvE
Region: EU
Mods? : No

Bug Description:

Still the problem with launching the game… I see that the game runs anywhere in the backround when I open task manager but I cant get to it…the funcom launcher always says loading…I tried all of the solutions mentioned yet but none of them worked for me please let me know if there is another solution

Expected Behavior:

Game launching like it did before the new update

Installed Mods:

no mods installed

Did you try launching it from the exe directly and by doing so bypassing the launcher completely?

With and without BattlEye:

What are the specs of your PC, do you use a standard monitor? Do you normally rum the game in fullscreen.

1 Like

yeah already tried that…nothing happens…I have an intel i5, 16 gb RAM, GTX 1070 ti and yes I use a standard monitor and i think i run the game in fullscreen normally

What happen if you try launch a SP game. Not joining a server, on the FC launcher just hit launch, not continue, do you see the main-screen where you can chose, or does it never show up ?

The game doesnt even open…I press launch and then there’s loading and nothing happens

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.