Last step of thrall taker journey will not complete

Platform: Xbox Series X
Issue Type: Other
Game Mode: Online Official
Server Type: PvE
Map: Exiled Lands
Server Name: 2507

Bug Description:

Last Journy step for Thrall taker will not complete

Bug Reproduction:

Tried applying Stygian Tanner I to tannery, artisan table and tanner’s bench and last step will not complete. Yes, I made sure to manually apply it to the thrall spot and did not just leave it in the workbench inventory. Also, did hard reset of xbox, cleared cache.

I was actually able to fix this, but thought you should know that the problem seems to be related to the dismantling bench issue.

When you hover over the thrall in your inventory and pull the right trigger, it moves the thrall to the workbench inventory, rather than the thrall spot, like it used to before the last update(the dismantling bench bug). You would then have to go to the workbench inventory, press the A button and manually move the thrall in to the thrall slot.

as I mentioned, I tried the tanner on the tannery, tanner’s table and the artisan’s bench to no avail, but then I thought of something, I moved the thrall manually, as listed above, but this time directly from my inventory rather than the workbench’s inventory, directly in to the thrall slot and this time it worked and completed the journey.

Just thought I would let you guys know, as this is clearly a bug and also others who may be having similar issues

Should be all good. I’m not sure to call it a bug.

Oh it’s most definitely a bug as it was not the way things worked before the last update. Before the last update(for years), if you pulled the right trigger on a thrall in your inventory, it would go directly to the thrall slot rather than the workbench inventory. same issue with the dismantling bench

1 Like

I thought we were just talking about the journey trigger.

Switching inventory was working up to last patch, for sure, to use R2. You’re right I had to manually move them into the slot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.