Mysterious Figurine Disappearing bug

Basic Info:

Platform: PC
Storefront: Steam
Issue Type: Gameplay
Game Mode: Online Private
Server Type: PvE
Server Name: Fauna’s Server
Mods: =MODS=

Bug Description:

For Siptah, the Mysterious figurines do not appear in inventory when picked up

Bug Reproduction:

every figurine since the sorcery update is bugged and will disappear when you pick it up but wont show in your inventory


Thank you so much for this report! We’ve passed the information onto our developers for further investigation.


I have the same issue.

1 Like

Getting the same issue. Did not have this issue in Testlive. Please fix ASAP. Makes the Pools of the Grey Ones pointless.

Same issue

Platform: PC
Storefront: Steam
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvP
Server Name: 6005
Mods: none

Same problem with figurines ((((. I can use only figurines that were collected before 3.0

This is kinda strange issue really, it suggests they have several functions to pickup an item from the world and placing it into the inventory since other items in the world works to pickup.
Isn’t that a terrible way of coding for each item instead of a ‘global function’ to add whatever item it is to the inventory?

1 Like

Any updates? This is a pretty significant issue.


I tried to create figurines with the admin panel. That did not work, either. They appear under “Building”. Unlike other building pieces (like, say, a sandstone foundation), creating one does not put it in your inventory. It just says “Failed spawning 1x game item 1590”. That’s for the Shaqqai Figurine.

Update: Spawning them with the console does not work, either. Would love to know the ItemId that people see that still have one of those figurines in their inventory.


Maybe this will help. Spawning the Figurine via Consol or picking one up will diplay this error into my Server log:

ItemInventory:Error: Data: Character does not own the DLC for DLC item 1602
i miss only 3 DLC: The Riddle of Steal Architects of Argos and Treasure of Turan

Any updates?

Still cannot pickup mysterious figurines. Any word from the devs?

Please fix this damm bug, pools are useless 30% of the game is missing !!!

1 Like

Yes I have this on my servers as well… ALL PLAYERS.

I have verified the files.
I have re-installed that game on my servers.
Yes, it’s the 3.0 UPDATE - sadly…

Yes, this one crippled this map.

1 Like

yep, same issue. very not good for Siptah adventuring.

Any update?
Just cant play without It.

Seems like they fixed it but no mention of it in patchnotes, just picked one up and it ended up in my backpack!
Edit. nope. not all statues work atleast -.-
Picked a few up around the pool of the grey ones earlier so thought it was fixed. But not for every location…

It looks like they have corrected all but one:

Shaggai Figurine is still not working

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.