Purchasing items from NPCs does not work

Game mode: * Single-player*
Type of issue: Bug
Server type: PvE
Region: North America
Mods?: Yes
Edition: Steam

Bug Description:

When approaching an NPC merchant like Shawma the Strange or the Mountaineer, I see the option to “Purchase: for [whatever].” It does not say what to purchase, and if I click on it, I lose a fragment of power or gold coins or whatever the purchase requirement is, but I do not gain anything–no schematics, no rocknose egg.

This affects the Library of Esoteric Things, too. I can interact with the library, and I will get a popup saying that I have “accessed the dark libary.” However, I get no feat, and I get no scrolls. Fragments of power are consumed, however.

I have attempted to purchase rocknose eggs from Shawma without any mods activated. Same problem.

Finally, attempting a workaround of simply spawning the schematics also does not work. Both the schematics (ID 29000) and the rocknose egg (ID 19026) return “failed spawning 1x game item [id]” when admin mode is on. This makes me think that the item does not exist, which is odd.

Expected Behavior:

I expect to get the items or feats I am purchasing from NPCs or the Library of Esoteric Things.

Installed Mods:

  • Kerozards Paragon Leveling - Reloaded (Steam Workshop id=1629644846)
  • Automatic Fish Trap (Steam Workshop id=1629644846)
  • Waystones (Steam Workshop id=2424793128)
  • One Tap Truncheons (Steam Workshop id=1399700746)
  • Better Thralls (Steam Workshop id=931088249)
  • Emberlight (Steam Workshop id=1369802940)
  • Less Building Placement Restrictions (Steam Workshop id=1369743238)
  • Unlock Plus (with Pickup) (Steam Workshop id=877108545)

Steps to Reproduce:

  1. Approach an NPC merchant like Shawma the Strange or the Mountaineer.
  2. Interact with them.
  3. Click on “Purchase: for [currency]”
  4. Notice that you’ve lost 10 gold coins (for Shawma) or 1 Fragment of Power (for the Mountaineer) but gained nothing in return.

Then, attempting to spawn the item via console command:

  1. Enable admin more in settings.
  2. Open command console with ~.
  3. Type in spawnItem 29000 1
  4. Notice it returns a failure to spawn error.

Just to see if it’s a problem with all merchants or just NPCs that sell those specific items, I went to Sepermeru. All the merchants I checked there had no problem selling me items. Their purchase interaction also specified what I would be getting.

Instead of the button saying “Purchase: for 10 Gold Coins,” it would say “Purchase: Elephant Hide for 5 Gold Coins.”

This and the spawning error leads me to believe that for whatever reason those items simply do not exist in my game.

Validating game files does not fix the issue.

Greetings @aika,

Thank you for your report.

Have you tried to purchase the items without the mods activated?

I have. Same problem as before.

I’ve also tried to spawn the items without mods activated, and the problem is still present.

Thank you for the additional information. We’ll ask our team to check those NPC’s.

Please let us know if you encounter any other issues on our Lands.

1 Like

I also backed up my save and started a new single player game with no mods at all. I tried to spawn a rocknose egg and schematic again (with spawnitem 19026 1 and spawnitem 29000 1 respectively) and both returned spawn errors. So, it seems that those items simply don’t exist in my game, even though they should.

Edit: after validating files in the new game with no mods, the missing items are back. I will reload my old save game and try revalidating again.

Edit 2: Revalidating the files on Steam for my old save game did notify me that “one file will be reacquired”, but the items still don’t exist.

Ah, I found the issue! I had one mod that should have only added a few items to the game. It did add items to the game, but it also deleted a lot of them… somehow.

One Tap Truncheons is broken.

Removing that mod specifically and then re-validating the files twice fixed the issue. Re-validating files only once (which is what I tried at first) didn’t work. Twice worked.

Thank you for bearing with me and for the help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.