Shield sound effects broken in online play

Game mode: [ Online official | Online private/dedicated ]
Type of issue: [ Bug ]
Server type : [ PvP | PvE-Conflict | PvE ]
Region: [NA]

During any kind of online play (offical or private), using a shield to block enemy attacks doesn’t trigger any kind of sound effects. If I play single player the block sound is present and also has variations for type of shield used (wooden vs metal). Also parry sounds (if you swing into an enemy attack) suffer from the same bug.

I also tried it on a LAN server to rule out latency issues. Same problem; no shield block sound effect.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Start any kind of online play
  2. Get any kind of shield
  3. Block enemy attacks (preferably human opponents)

Result : No shield block sound effects

Also

  1. Start a single player game
  2. Get a shield
  3. Block enemy attacks (preferably human opponents)

Result: Shield block sound effect is fine and does include variations.

Can we get recognition of this bug from staff? It has existed for a long time and I’m surprised there’s only been one other post about it (that I plagiarized tbh). It makes combat with a shield feel very awkward.

I don’t recall if shield combat has ever had a sound effect for a block. If so, I guess you could “technically” say it’s not a bug but a design decision (or missed feature, whichever). As a fellow shield combaterer (if that isn’t a word, it now is), I wouldn’t say that this is a huge thing, but I’ll also acknowledge that it definitely breaks the immersion and would be nice to include (and also a good feedback response to know a successful block occured).

As for asking for recognition from Funcom staff, there are two things of note.

  1. It is the holidays. Like every year during this time, various members of the staff are now on holiday (and very soon to be all of them). Response time will be much slower until sometime in January.

  2. While I wouldn’t necessarily expect a response due to the previously mentioned holiday break, it is okay to tag @Community if you feel your bug report was missed (which, I obviously just did, so no need to do so again).

There are a variety of shield block sound effects, but only in single player for some reason.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.