Sound stops working randomly - Steam


#22

And you have tried to launch the game as admin? I’m admin too on my PC, but if you right click icon and select “Run as Administrator” that does not make difference? I know I asked this before, but just to make sure since you only said that you are admin of your PC, not necessarily said that you manually launched it as admin =) You could change Admin launch for SWL’s app, and if you do play via Steam make sure to do the same for Steam also. Once again, worth of try. You can get there by navigating to SWL folder, right click on SWL and select “Properties”, same for Steam.


#23

I did not know that Windows 10 is annoying and doesn’t run apps as admin if you ARE admin. Wow, Microsoft gets stupider and stupider! Thank you, I will try this tonight and set it to the default!!!

Is there a way to set it (I have developer settings open, even though I’m not a developer, but have been using computers since Commodore 64) to ALWAYS run ALL APPS and PROGRAMS of ALL KINDS as Admin permanently?

I hate that Windows keeps hiding more and more stuff from me with each iteration to make it “easier”.

Give me MS-DOS back, Sheesh!


#24

TBH, I’m ashamed to admit this but I do not know how to make Windows run all apps as admin (with the popup and everything that is) after 4 years in IT-field works :smiley: Never really have needed to make these kind of settings, usually it’s the opposite :smiley: I’m hoping this could fix the audio issues! I’m keeping my fingers crossed. I think after this we could double check your audio settings in Windows, just for you know… Double checking is never bad when it comes to computer stuff :smiley:


#25

I tried. Running as administrator made no difference, but now I always play that way. (The last 3-4 times.) Thanks for that tidbit of information regardless! : D
Oh, do you know how to do that without the pop-up? I find that “this wants to make changes to your computer” dialog box ANNOYING. If I downloaded an installer and run it, I want to change something. *shakes head*


#26

The popup is there for when you didn’t download something and run it. I don’t know if you can disable it in windows 10, you could in older versions but it’s not a clever idea. :v:


#27

\_(o.O)_/

That’s what anti-virus and anti-malware software is for, though.


#28

Uninstalled. Deleted all directories I could find that related to any TSW or SWL installs. Waited for days. Reinstalled today.

No sound. Just for SWL. All other games, including other Steam games, the sound works fine. So fraking frustrating.


#29

When you uninstalled the game, did you also delete any remnants of the game’s folder as well as the settings stored in %localappdata%\Funcom\SWL?


#30

All the things. About to do it again, just to make sure it is quadruple dead.


#31

I was hoping the Krampusnacht patch was going to fix it - it didn’t. :{


#32

Any new thoughts on this, anyone?

I’m at a total loss…


#33

I finally did the complete wipe and reload and… still no sound from SWL. First time that has happened.


#34

I have mine working once again, although I never know when it may be temporary. I checked for the most recent updates for anything connected to sound, BIOS, etc. No updates needed to be applied.

So I right clicked on the speaker icon in the system tray and selected “Sounds”. This brought up the Sound dialog box. Unfortunately I changed a few settings at once instead of my usual one at a time and test.

Under the Communications tab I changed it to “Do nothing”.
Under the Playback tab I doubled clicked Speakers/Headphones.
Enhancements tab, I re-enabled all sound effects, unselected “Immediate mode” and then checked “Disable all sound effects” again.
Under the Advanced tab I have it set to Studio Quality for the format and then deselected everything under “Exclusive Mode”.
Clicked OK to close the Speaker/Headphones dialog box.
Clicked OK to close the Sound dialog box.
Restarted Steam and launched the SWL patcher.

Set everything to Default in the patcher.
Launched the program.
Sound worked BUT Integer sound was still selected from an earlier troubleshooting session I did today when I checked it in game.
Sooooo I changed that back to Auto from the in game menu and re-launched. Sound still worked.

I have been here before and the sound has suddenly started working and lasted a couple of days, a week, and even a month.


#35

Never mind, lasted two reboots and now I do not have sound again. Well at least I was able to hear sound for about 6 or 7 missions yesterday. Back to troubleshooting I go but not today.


#36

I did some more troubleshooting and did not get anywhere. I had been pinged by a GM to open a ticket because they had ideas but come to find out they had misread this entire thread. Without sound this game is not worth playing so I am uninstalling for now.

Anyone else who has this issue with an Alienware system or the Realtek drivers and figures out how to fix please post here. I will continue to take a look from time to time. I will also look for any significant change in the sound drivers in the future (last update was back in November and they tend to have new ones every few months).


#37

I just tested with my old Alienware R51 X2 and Alienware 13 laptop, both with realtek drivers. I have sound working correctly. One thing that now actually did come to my mind when you mentioned Alienware… Have you tried to disable Alienware’s Command Center? I remember when I got my laptop that I did have sound issues with completely another game (it was more of a sound cutting off, not lacking completely) and I did fix that one by reinstalling Command Center.

Also for anyone else having this issue, since we have went thru almost every possible fix. Are you guys running with Win10’s Xbox game thingy turned on? It’s on Window’s settings, I have no idea if this could help but at least when Win10 came out it was recommended to turn it off since it reduced game’s performances a lot. Dunno, this is like trying to find a needle from a haystack


#38

Thanks for the response. I have actually uninstalled it and kept it off until the sound died again the time before last. I then installed the latest version. I have also tried disabling it.

I did find one of my external monitors has a speaker and it was showing up in the Nvidia settings as the digital sound out for HDMI. I disabled that completely just to make sure and still no love.

I had turned off all XBox related stuff but I had not checked since upgrading to Win10Pro (plus extra memory and drive space). Still disabled and thank ya for the reminder.

I did notice there are a couple of Realtek manager EXEs running. I may do a dump of all of the procs and the memory and see if anything stands out. Of course now I will have to reinstall the game to see if it changes anything. Which means more “data loading” while running through any zones (I always hit a zone or two just to make sure the issue is global).


#39

So a few changes and sound is working again and it survived a reboot.

Found a component of XBox I could actually uninstall instead of disable and removed it via the usual route.
Updated video drivers (which should not impact this).
Exited and then disabled the alienware sound center. There is a way to permanently remove it but it requires removing the Realtek drivers and replacing them with old ones and disabling Windows Update and I am not willing to go through that. So I disabled it from starting instead (Ctrl+Alt+del->task manager->startup tab->

As my previous post I had uninstalled the game due to sound not working so I also reinstalled.

I will update if the sound goes away.


#40

So far, so good. I have added a couple of temporary speaker items (anker bluetooth speaker, another set of headphones) and still have sound in game. I have hit a lot of zones and a few runs into deep Agartha when I have caught the announcements. Not a single hiccup.

So, I do not recommend replacing the Realtek drivers with the older versions without the AW Sound Center. You would need to disable auto-updates and that is a bad idea unless you are really good at applying patches manually. While exiting the program before did not make any difference, disabling and re-starting the system seems to have helped. Can only guess at that since I did more than one change at a time (yes, bad troubleshooter, bad!). If you update the Realtek drivers, it is important to check and make sure this stays disabled.

@EnigmaticPyro, not sure if you have seen the latest.
@Tipsu, thanks for re-pointing me back at the sound center and x-box services.

Below is the Task Manager, for anyone else who is not sure what I was talking about. Couple of different ways to get to it. I usually do the CTRL+ALT+DEL, choose Task Manager, click on the Startup tab, and disable anything you would like to kill from launching on start. I found this to be the easiest way to kill the sound center.

You can go through the Services tab to disable any of the X-Box services you do not need. Just right click on one of the services on the tab and choose Open Services. This will launch another dialog box and you can set the startup type to Manual, Automatic, or Disabled. You can also start and stop services here and see some additional information. When I troubleshoot I usually set it to Manual first and then move it to Disabled.

Try disabling things one at a time and restarting the system to find what works for your system.


#41

My sound just stopped randomly but sound worked on everything else on my laptop (itunes, hulu). I did this and ran the troubleshooter and it fixed the issue.