Sound stops working randomly - Steam


#1

Sound plays when the launcher loads. Annnnnd that is it. Deadly quiet the rest of the time.

This has happened multiple times in the past and just starts working again, also randomly. Worked this AM, does not work now. Worked for about a week this time. Uninstall and reinstall does not impact it. Changing the sound to default setting in the game does not fix it. Dictating headset in the audio setup in the OS does not fix it. Reboots, etc have no impact as well. Have never found any settings directly in Steam that might impact this but I might have missed something.

Hardware:
Alienware 17R4 - using built-in speakers or Seinheiser wired headset, same results.
Other Steam games play sound, no issues.
Other non-Steam games play sound, no issues.
Things like Netflix play sound, no issues.
Driver:
Realtek Audio 6.0.1.8351
OS: Win 10 Pro (same issue when it was still Win 10 Home)

Anyone else have this issue? Any ideas on what to do for a more perm fix?

I have been thinking about switching back to the Funcom account and not use Steam at all for this game. I have not done the second transfer yet, will going back over to a Funcom account 1) solve the sound issue or 2) mess up anything vanity wise?

Thank you.


#2

YES!

I am not playing with Steam, but rather with the Funcom direct download. I have experienced the same thing in the past a few weeks ago, and again today.

I tried submitting a ticket, and the first response was essentially “that’s not something we can help with, it’s too broad”.

I am playing on a brand new (had it only a month) MSi gaming Stealth laptop. i7-7 Intel, Nvidia GTX 1050, Windows 10 Pro. Also Realtek audio drivers.

(The full specs of my computer can be found here: https://www.staples.ca/en/msi-gs63-7rd-246ca-15-6-inch-gaming-2-8-ghz-core-i7-7700hq-1-tb-hdd-128-gb-ssd-16-gb-ddr-iv-nvidia-geforce-gtx1050/product_2894985_1-CA_1_20001 )

At this point I have “repaired broken data” twice today (since downloading the Dark Agartha patch), and at least twice before hand. This does not make a difference.

The sound is a really important element of the game to me.


#3

You guys probably tried this, as it is quite obvious, but I’ll just ask anyway.
You DID check the sound and music checkboxes in the launcher settings, right? They seem to randomly reset for me from time to time.


#4

Yes I did. They have never unchecked in my case.

I’ve also rebooted my entire laptop before posting yesterday (after repairing “broken” data twice). We’ll see if I have sound tonight or not. :confused:

I wonder if performing some kind of deletion of files (perhaps these, perhaps others?) as seen below before repairing data will solve the issue.

Could a GM or someone from Tech support weigh in on this, please?

EDIT: Yes, still no sound today, after the patcher makes the “you can start the game now” sound.


#5

Audio issues are difficult for us to diagnose remotely. There are a lot of variables in terms of hardware (onboard, internal and external audio cards, speakers, headphones). The settings for these can be changed in a number of places:

-The in-game audio settings, or the Options window from the main patcher window when starting the game.

-The Windows Audio/Sound settings from the Windows Control Panel

-Whatever configuration applications may have come with your audio hardware or your output hardware

If there is a conflict somewhere in these settings (such as one of them being set to a surround sound setup when you do not have surround sound speakers), it can cause problems or lack of audio. We suggest you make sure all your hardware drivers are up-to-date, check all your cabling, and then go through the settings in the above locations one by one and make sure everything is configured as it should be.

Unfortunately, we cannot provide direct support for sound issues at help.funcom.com/.


#6

Thanks for the replies all. If I do a full reinstall I have sound for a few days. No changes made to anything and it goes away again. I have checked the boxes in all of the areas and even uninstalled the Alienware sound app since someone else on another board suggested it could be an issue. Drivers are all up to date, including sound, harddrive, network, and BIOS. Still cannot figure out why it works for a few days to a week (randomly) and then stops until I reinstall. TSW works just fine as do all other games, both on Steam and off.


#8

Apologies for the basic questions coming!

Do you have the same problem in DX9 & 11?

In the Audio options menu, there’s a Troubleshooting tab with an Enable sound system tickbox and a dropdown menu for Sound output format, have you tried the different options there?

Does changing the in game audio options change anything?

Honestly no idea if any of that will help, but just throwing it out there.

I suspect the OP will probably have already found this out, but once you convert to Steam, there’s no going back. You can’t use the standalone Funcom client with a steam account, and you can’t convert from steam to funcom :confused:


#9

I’ll admit… I haven’t tried switching to DX9… It’s a brand new lap top so that idea to fix it never occured to me. All the other checkboxes I have clicked and unclicked. Multiple times in variations. XD

I suppose I’ll see if downgrading to DX9 does anything… (I really thought Direct X was more about video drivers only… I didn’t realize it had anything to do with sound? O.o; )

I’m skeptical about it, but worth a try as it’s the only (basic) thing I haven’t tried.


#10

Yeah, no idea if it’ll make the slightest difference, but when options are limited, it’s useful to try everything available.


#11

DX 9 made no difference. I’ve deleted the entire game and patcher, and am redownloading the patcher now.


#12

Idk if you have tested already, but try to manually update all your sound drivers. Realtek, headphones possible software, everything really. And manually. Meaning download the driver from manufacturers website and apply it yourself. Could also go to Windows’ audio options and untick the option which let’s Windows control audio (I cannot remember the exact wording of this since I’m not on PC atm, will check later).


#13

While the game is open, right click the volume control next to the clock in the system tray, choose “Open Sound Settings”, then click “App volume and device preferences” at the bottom of the window that opens and check what the game’s volume is set to in there. For some reason windows 10 keeps muting programs (for me it’s system sounds and discord) so it’s possible that’s what’s happening here.


#14

Hey thanks for that idea. I checked that, and it’s at 100%.

I tried uninstalling and reinstalling the game, that made no difference either.

Updated my Realtek audio drivers, too… (@Tipsu and someone else). I appreciate all the ideas…

Any others? Again the patcher’s tone to say I can “Start game” works beautifully… but the login screen and beyond has no sound. :confused: I’m miffed.


#15

Hmm… Have you noticed any difference between windowed modes? For example full screen, borderless screen and windowed fullscreen? I’m slowly starting to run out of ideas here… What about launching the game as administrator? I know these are quite basic things, but at this point I think it is worth to even try the most basic stuff :smiley:


#16

I have tried DX9 and DX11. The different windowed (or not) modes. New audio drivers. New BIOS. New graphic adapters. Played with the video settings to get a much lower framerate. Changed the resolution. rebooted time and time again. Restarted. removed. Changed the number of sounds. Changed when things make sound. Turned off all sound across the board and then re-enabled one bit at a time. With headphones. Without. With very expensive headphones and cheap headphones. Sound turned all the way up and turned most of the way down.

Today I decided to just uninstall the game since SWL is literally the only game having an issue. I love the story and without sound the game is worthless to me.


#17

Nope, different video options don’t affect it. And I am administrator. But thanks for random ideas! ^^

I’ve had a new issue lately (which might be related?) where the subtitles during the cinematic story cutscenes will repeat after the first 4-6 lines… Happened with Montagg for two of the missions in Innsmouth Academy - one the last time I played (after the reinstall) and one today.

EDIT: Any more ideas? This lack of sound is really frustrating and making me sad…


#18

Do you have other applications open while playing the game like a web browser? Some websites have a lot of ads that can use sound and might be taking the focus for your output device away from your game.

I’d also recommend that you look for any outstanding Windows updates, both recommend and required. You should also perform a full virus scan.

These are general suggestions, but it is a good idea to check these areas when you have a problem like this.


#19

Virus scan - been checked, none.

Web browser open - often but not always, makes no difference.

No outstanding Windows updates, however I may only be getting the “required” ones, so I may look for recommended ones.

Seriously it’s been no sound (aside from patcher “ready to start game” sound) since Dark Agartha patch.
Also, I went poking around in the Funcom folder to try and FIND sounds, and I didn’t see any anywhere (I was planning on deleting them and doing the RDB repair)… so, are all the sounds stored server-side now with SWL?

I appreciate the incoming stream of general ideas. Please keep shooting me more. I tried the method I linked to in Post #4 last night (about the Inventory stuck RDB rebuild), and that also didn’t make a difference.

And does any of that explain or correlate to the looping cutscene subtitles? (With Annabel Usher and Montagg specifically (so far)?)

Thank you @Umborls for the explanation.

Thank you.


#20

Windows was up to date, I do continual scans, put an exception in for the Steam folders, shut it completely down before launch. Nothing impacted.

When sound did work, it would work for a random length of time, usually X days. I did notice it would go away forever sometimes if I disabled sound in the game, even after re-enabling so I stopped doing that. Patching from Funcom did not appear to impact the issue one way or another. I have not re-installed yet to see if it will return. Sound did stop working, for the first time ever, in the TSW install. Not sure why, it was never disabled there.


#21

Just a quick update on my end:

Turned out the time for my automatic Windows updates was set for when my computer was off, so rather than downloading the next time I was on, it just didn’t download.

It’s all 100% up-to date now - and still no sound other than the “Start Game” chime.

… I’m sad.