Unable to finish archers journey

Basic Info:

Platform: Steam
Issue Type: Gameplay
Game Mode: Single Player
Server Type: PvE
Map: Exiled Lands
Server Name: =SERVER NAME=
Mods: =MODS=

Bug Description:

Unable to finish Archers Journey but able to finish all other journeys as far as I got in the game by now. I finishes the first three steps of the journey and then killes lots of enemies with my bow, humans an animals, but still the journey is not finished

Bug Reproduction:


Can you screenshot what step that was? I completed all archer journeys without an issue yesterday.

I tried but got the message, that new users are not allowed to post images.
I fail to complete the first archer jouney. I made a bow, some arrows, did the special shot, and then should complete the journey by killing an enemy with a bow. This last step doesn’t work. I killed exiles and animals alike, still the journey is not finished. Other journey have been no problem so far.

I had a similar problem with step that involved using a pick on a tree. I was using a steel pick. Then I realized that this was probably written for the beginner and tested as such. So I made a stone pick and the journey step updated when I used it.

My suggestion to you is to make the hand-crafted bow and try to kill something weak with it.

Good call. I crafted the basic bow as required by the journey and had no issues. Might be the bow that others are using causing the issue for them.

I gave that another try, even though I killed someone with a hunting bow before, but it didn’t work.

Solved. I jused flinthead arrows this time.

1 Like

I had a hard time doing this one too. the mob needs to actually die by the poison dot

Can’t finish journey with Hunting Bow and Flinthead arrow. What to do? Maybe bad translation in Russian?

Do you use mods?

Yep, leveling mod

That maybe the Problem

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.