Unable to Login (“Incorrect login information”), Login Works on Funcom Website

As of today, I am unable to log in to the game on my desktop computer. I keep getting the message “Incorrect login information”. It was fine yesterday, and every day before that.

I am able to log in to may account on the Funcom website with the same ID and password (I’m copying and pasting the password to make sure I’m using the same on on both the website and the game).

I’m using a direct Funcom account - not through Steam.

I’ve tried rebooting, repaired the SWL install, I’ve entered the password manually and by cutting and pasting, but nothing works.

I’m able to log in on my laptop, but SWL crashes on that so often that it’s all but unplayable (the SWL-nVidia bug which afflicts so many people).

Is anyone else having this problem? Any suggestions?

I don’t have the log in issue you have but I get the crashes on my laptop and desktop. I have come to just accept them at this point. I crash randomly despite repairing, on dx11 and dx9 and often when I zone in the screen never loads the map. Since the bug has been around a long time, they either can’t fix it or don’t plan too.

I’ve come to the same conclusion. But the behavior is a lot better on my desktop - on the laptop I can’t do instances, or group with other people, because the crashes are so frequent.

Frequent crashes straight to desktop is often an nvidia problem, though lately i hear a lot of ppl say they do better on dx9

1 Like

I’d heard that, too. I finally tried DX9, and so far no crashes in a couple of hours!

It’s not an nVidia problem, though - I don’t have the problem on any other game. It’s an SWL problem with nVidia cards/drivers.