Vanity Mirror not recognizing mouse input

Game mode: [Online private]
Type of issue: [Bug]
Server type: [PvP]
Region: [US]

Vanity mirror shows mouse pointer, but cannot click or select any of the options on the menu. If left mouse button is clicked, nothing can be done, one must “i” to open inventory to exit, or “esc” to exit. If one does not click with mouse button, one can use the arrow keys to go through the menu.

This happens on a clean DB, an existing DB, modded or unmodded. All have been tried and all have the exact same behavior.

I have also tried resetting my key commands to default - (which they were already) this has had no impact or improvement.

This is somewhat of a minor inconvenience, but it should be looked into since I do not think this is working as intended.

This is effecting everyone on my server, also it effects 3 private servers I am aware of, so I doubt the issue my personal settings, my server, or caused by my provider

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Level up
  2. Buy Vanity Table Feat
  3. Build vanity table
  4. Attempt to use.

Hey @Imppy

Thanks for the feedback. This seems an odd one since we haven’t received any other report. We’ll send to QA just in case they can reproduce it on their end.

1 Like

Since today’s update I have not been able to reporduce it without a mod… Who knows, TY

1 Like

I ran into the same problem on my friend’s PvE server with the added wrinkle that my character’s appearance spontaneously changed. He’s definitely running mods though.

This issue might be related to Pippi (if you are running the mod). The fix hasn’t been released yet:



@Imppy If you are using Pippi while having the problem with the vanity mirror, they posted a workaround to type something in Pippi chat right before you use the bench, then the bench works. I tried this workaround and it works for me at least :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.