[BUG] Can't complete Animal-related journeys / Isle of Siptah

Game mode: Online official (6439)
Type of issue: Bug
Server type: PvE-Conflict
Region: America

Can’t complete journeys:

  • Obtain an animal companion
  • Obtain a mount

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Getting baby pet (tried couple of them - lynx, camel, boar, spider, etc…)
  2. Growing them in Reinforced Animal Pen / Stables (for horse)
  3. Taking them when ready, placing on the ground
  4. The journey steps aren’t complete

I also tried to ride the horse, to fight with assisting pets - nothing changed.
Other journeys completing as intended.

This is very weird. I’ve completed mine without an issue but it seems that some people have troubles with it.

im having same issue i have a couple of pets now including horses and ostrich turtle lynx but still stuck on this step

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.