Bug report (?) : Steam achievements - Isle of Siptah : "The Other Gods" and "The Shadow Out Of Time"

Game mode: Solo mode - Isle of Siptah
Type of issue: Bug ?
Server type: None
Region: EU
Mods?: No

Bug Description:

Hello everyone !
I want to get the Steam achievements “The Other Gods” and “The Shadow Out Of Time” on my solo game of Conan Exiles : Isle of Siptah. I tried to achieve these in every possible way : as an administrator, without being an administrator, in creative mode, using different schemes or using different essences “???” maximum load in differents telluric temples… Nothing works there. Successes are never unlocked.
I create a new game and tried to reproduce the maneuver in the Lands of Exile without succeeding any more.
The other achievements were achieved without difficulties, mainly in administrator mode but these two achievements remain blocked for a reason that escapes to me and despite several attempts.

Is those achievements only unlockable online on multiplayer servers?

Installed Mods:


Steps to Reproduce:

  1. Connect to solo game choosing Isle of Siptah
  2. Select or no “administrator” mode
  3. Try to unlock the achievements “the other gods” and “the shadow out of time” by crafting an eldarium item based on a plan crafted from a deepening table ; by put “???” in a telluric temple at maximum load
  4. Nothing happens. You got eldarium item and summon the greater energy gate but still no achievements.

Thanks for your help !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.