Cannot buy items from merchants ISLE of siptah

asic Info:

Platform: PlayStation 5 (Digital Edition)
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvP
Map: Isle of Siptah
Server Name: 8008

Bug Description:

Every trader (at least on the north island on isle of siptah) is unable to sell items. i have the coins, even tried to buy without being overweight and restarting the game several times. i cannot buy any item from any merchant

Bug Reproduction:

tried to buy an item to finaly get epic armour

1 Like

I tried buying Black Blood Pickaxe from a trader located in that new camp where you learn Golem stuff - I had ~21 Obol coins and couldn’t make a purchase.

Sorcery merchants not only won’t sell me black blood sickle, but are unresponsive I can’t even “talk”

i tested more further, and im able to buy workers and fighters but nothing else. no supply cache, no tools, no eggs or items from normal traders… it is halting my playtrough a little, i hope they patch this soon!

Hello everyone and thank you for bringing this to our attention.

Passed this information over to the rest of the team for further investigation.


Hello Exiles

So has anyone noticed that the merchant who sells camels is currently broken? You just click on “buy” and nothing happens.

Is this happening to anyone else?

1 Like

We purchased :camel: last week however they are invisible most the time ar least on Siptah @Paolo1977


Yes this is happening to me at exiles land as well I can’t buy anything please fix this.

So this issue is still affecting me on our private server. I’ve tried removing all the mod data, resetting the item directory and npc conversation directory, and even uninstalling and deleting all conan exile files from my pc, then reinstalling the game. nothing works.
I’m also the only player it’s affecting is there a solution yet?

I’m experiencing the same issue, can’t buy items from any merchant, please fix it ASAP.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.