Merchants wont sell me stuff

The new merchants won’t let me buy any tools or thrall i have the stuff to make the purchase but wont let me


Welcome to the Forum. You are not the only one to comment on this. I made purchases yesterday but that’s on a private server not sure if it makes a difference @Vanguard9 @Community

I’m on a private server and this morning I had to log out and back in to get a merchant to sell me something. I bought a thrall yesterday with no issues.

1 Like

I’m also on a private server. I haven’t been able to buy from the merchants. I’ll go one step further, when I tried to buy the midnight Grove potion, it wouldn’t let me buy that does let me learn, but I’m probably going to have to make the potion to enter the grove. One of my favorite places to level up my thralls…

1 Like

Welcome to the Forum. My wife and I have been jumping from our private ps4 server and official trying to figure things out
This is definitely a learning curve happening. But we will prevail. @CovertDragon76 @Betty

1 Like

Having same problem


Yup exactly the same issue. And like I said, the midnight potion for the midnight Grove dungeon. We restarted it server so we all are starting over now.

same here , but I’m also having issues even teleporting into the new dungeon.

Hello, i was looking on forums about this problem too.

I can’t buy with Cristal Blood, same with thé head of kurak Can t sell them. Any merchand in thèse area. I Can’t buy item.

(But when i speak Merchand deal Obale for Peopel.
it’s working for buying Worker or Fighter)
But Can 't

I read too about Potion Minuit. Yesterday was samething for me. I can lear for craft but i Can t Buy it. With the meat.

Not working for me i try to buy (not work) .
I go trough the donjon.
I clear it.
Than teleport me back. i go trying to buy, still not possibel .

I’m going to try again today. Hopefully they did a quick fix… cross fingers

Me to on PVE-K 3053 PS4 Cant buy anything.

That problem is in my server as well can’t buy anything in Mek-Kamoses 3821 PvP official

Hello, same here i’m on an official server #8007 PvE and i can’t buy workers and yakith. I’m on ps4.

Private, Public, even mostly invisible Valeria won’t trade for this one.

Now it’s same here…
I try on PS4 m’y friend try on ps5. Not working

And for merchant New area for thé peopel with ps5 it IS working if they spammed there touch. But not working on each merchant .

1 Like

It’s not working for me on ps5, does not matter how many times I spam the purchase option I get nothing.

Not working on PVP official servers on PS4 Pro, such as the one I play (4508), it started only with the merchants near the new dungeon but now with all merchants on the map its not working.