Cant enter a server just kicks me back to title no matter what

Game mode: Online
Problem: Cant join server
Region: North America


When I try to load into a server, that I was playing on fine yesterday, it looks like its loading but then it kicks me back to the title screen saying “Could not connect to server. Your connection to the host has been lost.” How do I fix this.

Had this happen to me a while back. Had to wait to the next day after server reset before I could play unfortunately.

I just tried it but it didnt work same issue still. And my level says 19 when its 60.

Did you try clearing the cache on your Xbox by doing the hard restart?

Hello @MasterSpecter1, have you tried loading into a singleplayer session before trying to connect to that server?

Also, are any other servers giving you issues?

As Scumdog1980 has suggested, please try to clear the console cache as well by holding the power button for about 10 seconds until the console powers off, then disconnecting it from the power outlet for a couple of minutes.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.