Can't see or join servers

Online official | Online private
Crash | Bug
PvP | PvE-Conflict | PvE
I don’t know my server region. I live in NA

I cant see any servers in server browser. I cant join any servers through steam. I crash to desktop when I try to join directly through IP. I have tried: restarting my computer, reinstalling the game, verifying my game files, joining through steam>view>servers, joining through direct IP

Hey supremenastydogg, Same issue in this topic :

here is a helpfull link ( READ THE END OF THE HOW TO CONTACT US SECTION to be able to send DM’s ) the best would be a message with detailed screenshots :wink:

Make sure it’s not a firewall issue or a virus protection issue. - most likely

Click on “show invalid servers” in the server browser. if anything shows up there you have an outdated version - second most likely

or you are running the test live version, although the TL version should still show the TL servers.

it’s much more complicated than that , I have been through a dev school so I know a few troubleshooting methods.

no antivirus nor firewall active , when I ping the server (with the ip from battlemetrics) it just 100% packet loss , when I tracert it’s stop before ending somewhere in germany ( not far from the server since it’s also in germany )

with steam I verified the files , nothing , I made a new install of the game , nothing ,also tried via view > servers > add a favourite , the server is not responding ( but I see everybody else connecting to it via battlemetrics

heck I even tried connecting on my laptop ( with my phone as internet source AND with my normal ISP box )

it’s been 4 days now and I fear that If not resolved quickly I’ll lose 2869 hours of investment ( since I am the last of my clan playing regularly )

edit : weirdest part is that I see some servers (official and non official) ( and can connect to them to create a character ) but for each instances ( pvp / pve) my serverlist seems to stop searching as soon as it has filled the entirety of the list ( just before having to scrool to see other servers with the official filter on , and not with internet (default) filter )

I checked my firewall and the game is allowed. I am not running the TL version and I don’t have any mods installed

Reinstall Battleye Via wow64 file in steam. You’re welcome :slight_smile:

Did it , as well as reinstalling the hole game , scanning for corrupted files and all the troubleshooting methods , I called my ISP ( I have supposedly dynamic ip adress , but still asked them to change it ) all of this doesn’t change anything for my case

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.