Can't Upload Images

I recently tried submitting a piece of artwork to the MEGAversary art contest thread, but I kept getting the message, " Sorry, new users can not upload images." I’m a little perplexed as I’m no longer a new user on this site, and I was able to upload images using the exact same method just a few weeks ago. Is anyone else running into this issue, or is something weird going on with my account?

Post has been edited


How dare you! Here I am seeking help from the community on an issue that is very dear to me, and you casually post an image just to mock me.

On the other hand, I did find it amusing, so I’ll allow it.

Also, I just got a message from some user named “system” welcoming me to the community and saying I’ve earned their trust. That’s not at all suspicious timing. But hey, I can upload images again. So, problem solved, I guess.

Congrats! I was just testing to see if I was running into the same issue.

I gathered as much. And obviously, I was joking in return. Though someone flagged your post. Honestly, I hope it was just me by accident when I went to click the heart. I’d hate to think there’s people out there without a basic sense of humor. Or possibly it was the grammar police flagging it for the wrong use of “there”.


I thought someone flagged it for using “there” instead of “their”!


Now I’m going to flag your post for stealing my material.

1 Like