Conan exiles Boss stuck in ground

So apparently the boss at the end of the dregs is still glitched? Decided to do the dungeon for abysmal only to find final boss stuck in the ground at . Continuously spitting and making noise but not coming out of pool . I’ve tried logging out and leaving the dungeon but nothing. Arrows aren’t working either, Any way I can reset this boss or make this problem go away?


Hi @Explicitprincss1 and welcome to the community! Apologies to hear you are having difficulties with the Absmal Remnant. I would suggest following the template and doing a full bug report. The Abysmal Remnant has always been a bit problematic like this. For example, my partner encounters two of him when she gets there! As for a workaround, you could try either some Explosive Arrows, or even better, toss a whole bunch of Gas Orbs into his pool and see if the their area of effect reaches the big stop-out. Let me know if it worked ok?

1 Like

Welcome to the Forum Exile. Finished Dregs for the first time in years been on Siptah playing ps5. Had 2 thralls. Used a bow killed the worm quickly could not see the book in pit just kept spamming square button. Realize @Croms_Faithful info is always good. You might recall him as the cook from Sinners Refuge yes he Ancient. Lol. @Explicitprincss1