Controller on PC not working

When I try to use my Xbox One controller it only registers my thumbstick but not any or the buttons. Is there a good fix for this?

I am having the exact same issue with my PS4 controller. Have the devs really not answered this topic in 6 months??? If so that’s an absolute disgrace. I am handicapped and need to play with a gamepad and cannot get it to work with this game even though it is tagged on steam as having full controller support

Hello @count2potato, thank you for reaching out and welcome to the forums!

MYZ has full controller support, could you share further details so that we may best help you?

Is your controller a PS4 original or a compatible third party?

Do you have any custom / third party software installed that could interfere with your controller?

Are you playing the game through Steam?

Is the controller detected if you enable it while in-game?

If you access the Controls tab within the Options menu, is the Keyboard/Gamepad set to Automatic or Controller?

I just created account because i have this problem too.

My controller is original (works in other games on PC)
I dont have any custom / third party software installed that could interfere with my controller
I play through Epic Games
Game doesnt detect my controller
I tried with automatic and controller

Same problem here. PS4 controller, I tried using DS4Windows and without it. I tried to plug it and to use it via BT. The controller is recognised by Windows and works with Steam and other games. This game doesn’t recognise it.

Welcome to the forums @verti and @n_malo !

Just to clarify @verti, can you confirm your controller is an original PS4 one?

@n_malo, can you confirm that you’re playing the game through Steam?
Did you also try setting it to Automatic and to Gamepad?

It is definitely an original PS4 controller.
Last year I bought a new original PS4 with 2 controllers so I am 100% sure, they are original.

Hi Hugo. I’m playing the game through epic, not steam. The controller is an original DS4.
I tried setting both auto and gamepad, no luck.

1 Like

Thank you for the additional information, we’ll make sure to poke the developers so they can look into this!

1 Like

Have the same problem. PS4 controller, play through Epic Games Launcher

1 Like

My XBox One controller works fine.

ASRock Z77 Extreme6 LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
Gigabyte GeForce GTX GV-N1080G1 GAMING-8GD
Ram: G.SKILL Sniper Series 16GB (4 x 4GB) 240 pin DDR3/SDRAM DDR3 1866
Intel Core i5-3570K Ivy Bridge
3.4GHz (3.8GHz Turbo) LGA 1155 77W Quad-Core Desktop Processor Intel HD Graphics 4000
1 X HD 1 TB Western Digital Black 7200 RPM
1 X HD 2 TB Western Digital Black 7200 RPM
1 X HD 5 TB Western Digital Black 7200 RPM
1 X HD 300GB Western Digital VelociRaptor 10K RPM
2 X ASUS 24X DVD Burner
MS Windows 7 Professional 64-bit
PWR Supply: Ultra 3X 1000W SLI Ready
Antec Twelve Hundred V3 Case “Full Tower”
Monitor: Samsung S27D590CS, LED Lit, Curved Screen, 1920x1080
Logitech X-230 Speakers
Logitech Gaming Mouse MX-518
Logitech G810 ORION Gaming Keyboard
SteelSeries Gaming Headphones V-2
Logitech HD Pro WebCam C 910
External BackUp Drives:
Fantom Drive G-Forcee Professional 6 TB 7200 RPM USB 3.0
Rockstor Drive 2TB 7200 RPM USB 3.0

I also am having the same issue, original DS4 through the Epic Games Launcher. It doesn’t work.

We’ve had reports that PS4 controller works with DS4Windows v1.4.52 installed, so we’d suggest trying out using that specific version of the software.