D3D Device Lost cause my game, and sometimes pc, to crash

Game Mode: Single-player(Custom, no mods, but all DLCs).
Issue: Crash due to D3D Device Lost(whatever that means).
Server Type: Single Player, PvE.
Region: Northern Europe.

I got the Core game and all the DLCS installed.

I finally got around to play CE this past Saturday… i Installed it, and launched game. picked “Cancel” to the in installation of Battleye, as i dont plan to play anything but singleplayer.
I started a single player game(Custom), but dident mess with graphic settings.
I played for about 4 hours until rl disrupted me.
Game ran like a charm.
I continued playing on Sunday, and when i again was prompted to install battleye i picked cancel again with the “dont ask again” button flagged. But after about 5 hours, i decided i wanted to recreate my character and start from scratch. But before i did, i turned on admin and teleported to a few map places i was interested in building at, picked god mode and invisibel for that.
Then i logged out to main menu, and quit the game.
When i did this, i was greeted by 2 windows, what they where i dident pay much attention to unfortunately, but one said something about conan exiles, and said “Fatal Error”. I clicked the ok button, but nothing happend at first, but then screen went black, and pc was rebooted.
This freaked me out because despite having been gaming for more than 2 decades, ive never had this happen.
Then today(Wednesday) i decided to play Conan Exiles again, and hope the crash after exit was a fluke.
I also updated my graphic driver yesterday, because i noticed a new driver was up(i update as often i can).
I got as far as the character selection, when the game crashed during character creation.
Was a “D3D Device lost” Error.
As i was playing full screen, all i could do was Ctrl Alt Delete and log out of windows. And ofcourse log back into windows.

I tried google a bit and made some changes… i turned off the Nvidia overlay, i also tried optimize game in the Gforce experience window.
Ive also tried turned graphic settings down and up, and anti alias thingie up and down,
and ive tried playing in full screen window mode instead of plain full screen.

But everytime i play the game, the game crashes because of D3D Device lost.
I dont get further than to the newbie river before the crash happens…
luckily the last few crashes dident crash the pc but just the game… probably because i was in full screen window mode, or had the overlay turned off?.

My pc is a stationary one… 3 years old, and it was probably considered high end when i bought it.
I really want to play this wonderfull game, but i cant play it.
Whats weird, i think, is that on saturday and sunday i could play for hours, with no issue whatsoever.
Only change to my Computer or game before the crash on exit on sunday, was that i had flagged the “dont ask again” for the Battleye install prompt, and that i played a bit with Admin in my game.
And only change after that first crash on sunday, i updated my graphic drivers, when it became available. But i had a crash before i updated the drivers, so i cant see how that could be the issue.

I really hope someone can help, because i die a little inside everytime game crash, and its unplayable now since i at most can play a few minutes.

Also, i am by no means a computer wizard. Heck a “pc for dummies” guide would be WAY to Pro for me :frowning:

Hello Kausten,

For the game to be running fine one day and not the next with no changes made to the system that you’re aware of, and persists through system restarts, likely reasons might include a disk or memory error that caused some form of corruption (Windows/driver etc.), or you had the misfortune of receiving a problematic Windows Update.

You might attempt a System Restore and look for a recent restore point just before you started having problems. System Restore should uninstall recent Windows updates and can repair some corrupt files. If you can find a recent restore point before the problem started and invoke it, I’d try playing Conan Exiles again immediately afterwards and see if the issue persists.

Be aware this should roll back your recent NVIDIA driver update as well. I’d wait to update that again until you find out if CE is working or not. Good luck!

Hi, thx for trying to help :wink:

But not sure how or why i would be getting a disk or memory error… i already tried atleast looking at rolling back windows to a previous update, but it said more than 10 days had past since last point or something so i couldent.
Which is a little weird as i could have sworn i recently installed a windows update… it was one of those i could choose to install, but wasnt “forced” to install…
But pretty sure i installed that update before i even started playing Conan Exiles…

Ive tried running dxdiag to see if that showed some errors or something, but nothing to see there… well plenty, just not errors :stuck_out_tongue:

If its a windows issue, i guess im screwed? Just weird i could play for hours, on 2 different days, and then now i cant play for more than a few minutes…
Well weird to me… heh

Corruption could have occurred as a random glitch, due to a power fluctuation or outage, or due to defective/failing hardware. Any issue, whether it happened just once or could recur, anywhere between the hard drive, motherboard, and memory could have altered data stored on your hard drive somewhere it shouldn’t have and caused an issue that persists through restarts. Damaged file(s) that are part of, or used by the operating system, can cause all kinds of issues.

Although it’s possible you might have defective hardware, that’s much harder to diagnose and much more expensive to repair, so I’d try to rule out less catastrophic issues first.

If you have other newer games you play, it might be helpful to check if they seem affected as well. Otherwise maybe some part of Conan’s data is corrupt. You might want to try validating it from your Steam Library to be sure. Right-click it in your Steam Library, choose Properties, go to the Local Files tab and click Verify Integrity of Game Files…

If that doesn’t help, and if you can’t initiate a system restore, following this guide (assuming you have Windows 10) may help you check for and repair operating system corruption that might be preventing Conan Exiles from running.

(I use an ad-blocker, so my apologies if that site is loaded with flashing banners or anything else obnoxious.)

I would suggest you skip trying Solution #5 if you get that far. If corruption is at play here, hopefully this guide helps you fix it well before you get to Solution #7, because reinstalling all your stuff isn’t much fun. If you have a lot on your PC you may want to hold off on that step (and the Windows re-installation recommended after that) and investigate other possibilities before taking actions that might be unnecessary.

Anyway, no guarantee your problem is one of these, but it seems like a good place to start. :slight_smile:

1 Like

I’m having the same issue, with an AMD graphics card.
@Barnes And I have been looking at the problem.
And we are also thinking it’s a Windows 10 error.

1 Like

So i did validate my CE files already after sundays crash…

I did that SFC tool thing and it dident find anything.
So i tried playing the only other “newer” game i got on the Computer… Which was The Long Dark.

I played for about 2 hours, then game froze while i was in a cabinet, i could hear stuff, but couldent do anything, not even get to windows… so a few Ctrl Alt Deletes and pc rebooted… i think… but is now basicly broken… cant turn it off or see anything on the screen…
So… being a pc noob, i guess my issue is more severe… maybe windows 10 is basicly broken, or my pc is having some major issues…
Guess i need to see if i can get it to the shop and they fix it…

Thanks for trying to help thou… guess now is the time to throw away some money and get pc fixed, or windows fixed if it is actually windows thats has a problem.

Just goes to show how lucky i be… finally got the time to play a game ive been wanting to play for a year(its been in my steam library for that long waiting), and then the powers that be… must be Crom decide to rob me of some fun time :frowning:
Well luckily i got this, about to die, old pc i can use, thou its much to weak for CE unfortunately…

1 Like

As @droch-aon says, this is something he’s experienced recently, with regard to his machine. (I hope that’s accurate, dro, that it hasn’t happened before.) In his case, it may well be a Windows 10 issue, but with yours please keep reading. :slight_smile:

I’m just another player, but I’m also a PC technician, and I’ve been tracking a number of these sorts of graphics issues since the Mounts and Movement Update. I also have been watching these errors from far back in the game’s history as they’ve cropped up from time to time.

The issue is more than likely within your graphics card’s settings, drivers or both.

Here’s an earlier thread I’ve been referring out for a while:

Pertinent info in the above thread: If your PC has on-board video in addition to your add-on Graphics Card, the best solution is to disable it. This can be accomplished in either your System BIOS, or through your Device Manager.

Good luck, please give feedback. I’m sure we can get this nailed, and get you back in the game.


I’m sorry to hear that. It does sound like something more serious may be going on. Crossing my fingers for you and hoping that it’s a simple and cheap fix!

1 Like

I read that this error, occurs with and on board GPU coupled with a Vcard GPU
and disabling the on board, fixed the issue.

This made me think about the difference in my system from when I played Conan without this error, and now. The difference is I use Two Monitors now.

So I thought what if the problem isn’t just two GPU’s but also Two monitors?

I found a freeware program, that locks the cursor to the monitor while playing a game that isn’t optimized for multi monitors.

I’m still testing, But I’ve now played two hours without this problem.
I’ll report back, if anything changes.

No Joy, Error still occurs

@droch-aon Hello I have the same problem.
It occures when I am logging in to server.
Error message:
Fatel error:
[File:E:\branch_exiles-live\code\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 181]
Unreal Engine is exiting due to D3D device being lost.
(Error:0x887A0006 - ‘HUNG’)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.