Demon Fire Orbs do NO damage to enemy buildings!

Game mode: Online PvP
Problem: Bug
Region: Europe server 3159


I finally found an alchemist at the Black Galleon. I slaved him and make him work at my cauldron.
I saw the demon fire orbs unlocked and I was so excited! I ran up and down the freaking mountains and caves, killed a lot of lizards to get volatile glands bla bla bla…I got all I needed. I was ready to start my reign of terror! I found a big sandstone mansion that was looking pretty fat so I jumped on the roof to have a clean and plain pice of sand storm to burn(I knew already that the precision of the orbs is just awful. why nobody is doing something for thta problem?).
[The problem actually starts here! :smile:]
The healt of the roof was full at 7.000hp
I throw 2 grease, 1 fire orb and after 15/20 sec another grease to keep the fire. I was smiling and already smelling blood… BUT… when the fire stopped the SANDSTONE roof was still there FULL HP like nothing happened! WTF!
Ok maybe that quantity is not enough to breake throught but…NO DAMAGE?!
I tried couple more times with different buildings(all sandstone) but nothing my freaking orbs DO NO DAMAGE!
May I have an explanation please? Is 3159 the worst server ever or there are other problems?

Sorry for my english


Steps on how to reproduce issue:
1.launch grease orbs
2.launch fire orbs
3.No Damage

Hey there,

Damage to other players and buildings can only be done during the server’s designated raid times, which generally are from 5pm to 23pm.

Ooooh I tought that was just a setting in the PvE.
So even in the PvP we have specific times? the server I’m playing is official.

On PVE-Conflict there’s also designated raid times, with the difference of not being able to destroy other player’s buildings contrary than on PVP servers in which both players and buildings can be damaged during such raid times.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.