Download Client

I have finally upgraded my pc and want to download the non stream client. Funcom’s page does not seem to work … any suggested sites to help install this game again.

ageofconan.com isn’t working? There’s 2 buttons there you can hit the ‘play free now’ or a bit farther down on the right side is ‘download client’.

This site can’t be reached

Check if there is a typo in https.

  • If spelling is correct, [try running Windows Network Diagnostics](javascript:diagnoseErrors()).

DNS_PROBE_FINISHED_NXDOMAIN

The link, Nebless posted, is working fine for me.

I just checked the link myself and it works fine.

What country are you in? As I’m pretty sure there are some countries blocked and it’s possible that’s why you can’t download the game.

I’m am trying to download from the US. Tried different computers and internet services, when I click download client I got the error that I posted above.

You can try from your account page: https://account.ageofconan.com/
After you log in, on the Account Services tab, there’s the link to download the client.

thanks that link worked

1 Like

Funcom wants to kill the game so badly they took down the public link for the client?

Yup. Its even worse for anarchy online. You have to log in to secret world to activate accounts in that game after they completly broke the account page.
Looks like funcom is on a suicide mission at this point.

Download it from steam.

That’s probably why they disabled the direct download. To save money on bandwidth. the client should be downloaded from steam and then updated. @op you do realize that even when the direct download worked, it would only send at a minuscule trickle rate and could take a few hours or even a day to download the client data right?

If you don’t have steam, get steam and get it from there. you would have already been playing by now.

Sorry to dig up this topic… This will surely help…

The working link is: http://aoc-us-update.live.ageofconan.com/download/AoC/EU/ageofconan-en.exe

Why is it not working on ageofconan.com?

When hovering over the link we see “https//aoc-us-update.live.ageofconan.com/download/AoC/EU/ageofconan-en.exe”, the “:” is missing. the site probably has to analyze the link by looking for “https://”, not finding it, it adds “http://” which gives “http://https//aoc-us-update.live.ageofconan.com/download/AoC/EU/ageofconan-en.exe” making the link non-functional…

This problem is present for some other links, notably pagination links.

1 Like