Dreg boss does not spawn

Hi, tried yesterday the dungeon three times. I reached the boss pool can hear its voice but there was nothing inside the pool. Is this a bug?

I was playing on an EU official server in PVE.


1 Like

What system are you playing on. You may want to try logging on and off. Have not heard of any one having problems lately.

1 Like

Have you asked on the global chat if someone had done the dungeon before you? When the boss has been killed recently and hasn’t respawned yet, you’ll still hear the voice, but the Abysmal Remnant won’t be there.

One way to check if it’s a bug is to sit there for 30 minutes. It’s boring and it sucks, but if it doesn’t respawn after 30 minutes, then it’s definitely a problem with the game.


Hi guys, thanks for your reply. I tried more than once to disconnect and connect again, I camped in the boss pool for thirty minutes as well. Strange thing is i could not do the puzzle with bow because the mechanism worked on itself filling and draining the water. Strange really…

Anyway thanks again i will try on solo on another run.


I have seen it with the switches going on by themselves with no one else around. Also acid pool refilling as I was reading the book died on that one.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.