Dryer Meat, Texture and other Issues

Console: Xbox One

Region: LATAM

Gamemode: Single player

Dried meat does not appear hanging from the dryer.

And the terrain textures, along with the textures on the character’s muscles or the worldview are slow to load.

Good Day

Ps. From the Khitan camp on the volcano there’s one “lost” merchant to get the top of the Mad Prophet’s armor.

Greetings Exile, and welcome to our forum!

Thank you for your report. We will ask our team to investigate the dryer and texture issues.

Regarding the “lost” merchant, can you share more information?

  • Is the merchant elsewhere or entirely missing from the game?

Also, in the future, please provide individual bug reports for each bug you find to keep the forum tidy and assist us in further inquiries.

1 Like

Good afternoon.

Sure, about the “lost merchant”, I mean that in the area of the volcano where one of the Khitan slavers’camps is located, some of the NPC’s do not appear there.

I was already playing a couple of hours & by the time I had enough obolus coins to buy the last part of the Mad Prophet’s armour. So I went directly there to by it from one of the traders & apparently one the a few of the NPC’s were there, like as if the rest did not exist, & this does not allow me to complete said armor & equipment. It seems to me that it is bugging.

Hope that this information can help you a lot to fix it together with the previous report.

Thank you.

Thank you for getting back to us. Could you share some pictures of what you see in that camp?

Could you also let us know if you tried to walk around the area and see if there’s any interaction possible even if the merchant doesn’t visually show? As we are aware that some assets might be invisible/not rendering at the moment on consoles.

We appreciate your assistance in this matter.

1 Like

As you are looking at bugs at the Volcano no one has mentioned the invisible Golden Lotus, bad enough getting cooked getting it but now it’s invisible it’s like the holy grail of lotus seeds to get.

I tried to move through different areas of the zone, even waited five minutes without moving on the same point & then nothing happend.

Sorry, but as a new user I can’t share images of the game, I don’t know why.

1 Like

Hey @RokyWolf,

We updated your forum rank to allow you to send images and links.

Thanks again! :slight_smile:

1 Like

There:

Greetings,

Thank you very much for the information and pictures. We’ll ask our team to continue to investigate this issue.

Have a great day! :slight_smile:

1 Like