Excessive crashing D3D, DirectX, Device Lock error?

Game mode: [SELECT ONE] Online
Type of issue: [SELECT ONE] Crash
Server type: [SELECT ONE] ALL
Region: ALL - Multiple
Mods?: Both, yes and no.
Edition: Steam


By my count there are 7 people (six others and myself) now recently having this issue:

image

Since the last patch I get this error on about 35 to 40% of game loads - yes, really, that much, zero exaggeration. It errors and then dumps itself out of RAM completely when the OK is clicked.

  • Happens on official servers,
  • Happens ONLY in Conan Exiles.
  • On a new windows 10 fully updated installation 21H2,
  • Healthy SSD/HDD,
  • Both UT4 and UT5 are installed and used professionally 2 days a week,
  • There is no Battery Boost option in GFE for DT PC,
  • Latest Stable GPU Driver - 2080ti
  • Running in a 1440P bordered Window on a true 4K HDR 10+ 120Hz monitor,
  • GPU is temperature limited at 77C,
  • Steam verified and Game reinstalled,
  • Asking a player to disable Firewall Software should be considered a crime punishable in a court of law!
  • No 3rd party AntiVirus runs here - ever.

In my case I have just been sending the reports via the “Send Report to Funcom” button you see there in the screen shot. I have sent somewhere between 50 and 100 of them.

It happens almost but not 100% exclusively on the screen you see in the screenshot clip here. Rarely it will pop up it’s ugly head after 10 to 20 seconds of gameplay. When that happens the game animations and timers continue to run and update but in dismissing the error dialogue via OK the game dumps. In extremely rare cases the error dialogue pops up after some hours of gameplay - so like, twice in about 60 to 80 total crashes.


If it helps at all this error dialogue is followed by one of these texts being placed into the windows clipboard:


Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 805]
Rendering thread exception:
Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 181]
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)

!0x0000000000000000


Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 232]
Result failed
at C:\B\tech_exiles\code\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Query.cpp:134
with error DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG


Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 959]
GameThread timed out waiting for RenderThread after 60.00 secs

!0x0000000000000000


It’s almost always the top one but it can be the other two as well. The later two seem to happen when the screenshoted dialogue box occurs (pops up) during gameplay well after the load is finished.

Concerning that last error clip, nothing was visibly waiting or hung - certainly not for 60 secs.

Also, no related errors appear in the Windows Even Log - nada, nothing.


Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Install Windows 10 Pro and update to 21H2
  2. Update all drivers
  3. Install Steam
  4. Install Conan Exiles
  5. Attempt to load Conan Exiles. (~30% of the attempts crash)

This began happening sometime after 2.8 and fairly close to the hot-patch. The crash has occurred more than 50 but less than 100 times. It typically happens two or three times before a successful load can be completed and the game normally played.

1 Like

So it is not an AMD driver update issue. Thanks!

I tried other games - both old and new, and indeed, Conan is the only one crashing.
Tried older and the newest graphics drivers - no success.

1 Like

Yeah, it (seems to be) some sort of device locking issue on Funcom’s side. (Software or hardware “device”). I think I notice it happening more often if there is other software running… Like Opera / Chrome Browser or Discord. That may be my imagination tho as it also happens without them ever being loaded - but just seems less. Both those aps and many others make use of Direct X devices and functions. Of course this is just a total guess and it could be something much simpler Funcom introduced in the previous couple of updates/patches.

But yes, I’m running an NVidia 2080ti so it’s likely not due to AMD’s graphic drivers.

I’m also throttling the GPU via temperature. It’s not allowed to exceed 77c. But I’ve tried it with that on and off. The card draws as much as 280W under that limit but is powered by a very reputable 1200W PSU. The CPU is the 5600X which hardly ever draws more than about 15W as I have it configured. There’s 64GB RAM currently installed and they check out as good. MB BIOS settings are all good and proper for a gaming rig. etc.

Yeah, for sure, I’m 98% certain FC introduced something that is affecting some installations. As evident from their Stacking-fix-fiasco they rely too heavily on the user base for debugging and don’t seem to do a lot (enough) of in-house debugging before a release.

I hope they’re able to identify this pretty soon. It makes loading the game a tedious task of Russian roulette… :stuck_out_tongue:

1 Like

Hello, did you find exactly what Application makes the GPU error?
I have the same issue as you!

1 Like

Yes… Conan Exiles, from Funcom.

Seriously. It happens even from a cold start, safe boot, or anything. It’s not related to other applications, BG tasks, or utilities… it’s all CE. I thought maybe I was noticing that it happened less if nothing else was loaded before or during but I’ve since ruled that out. Now I’m thinking that it happens less if you start the game via the FC Loader’s Launch button and allow the intro video to play for awhile. As opposed to loading the game via the Continue button. At least I’ve had 4 good loads in a row today without that error - which is against the odds, so…

BTW, If you @RainyDay, @rolee9309 and maybe @elna111 too, could add your full hardware and software spec maybe we could find a few things in common to help FC nail this down… Just copy and paste this and fill it out to the best of your ability if you have the time:


  • Windows Version:
  • BG Tasks & Utilities running (like Afterburner, discord, skype, etc):
  • Web Browser:
  • CPU Model:
    • Overclocked (Y/N):
  • GPU Model:
    • Overclocked (Y/N):
  • System RAM amount:
    • Overclocked (Y/N):
  • Game location (Drive Letter + HDD/SSD/NVMe?):
  • Motherboard:
  • NIC (Network Interface and/or driver name):
  • Line Speed (ISP):
  • Connection Speed (PC):
  • Other Internal Devices:
  • Peripherals (USB, Thunderbolt, eSATA, etc.):
  • Sound Card/Device:
  • Audio Connection:
  • Comments (something I forgot?):


Here’s mine:

  • Windows Version: Win 10 Pro 21H2
  • BG Tasks & Utilities running (like Afterburner, discord, skype, etc): Tested with none and also Afterburner, Skype, Line, Discord, Opera GX, Sidebar, GForce Experience, Steam.
  • Web Browser: Opera GX
  • CPU Model: AMD 5600X
    • Overclocked (Y/N): Yes (but also tried without)
  • GPU Model: 2080Ti
    • Overclocked (Y/N): Yes (tried without too)
  • System RAM amount: 64GB (also tried with 128, and 32)
    • Overclocked (Y/N): Yes. (DOCP Stable)
  • Game location (Drive Letter + HDD/SSD/NVMe?): X: HDD
  • Motherboard: ASRock X470 Taichi Ultimate
  • NIC (Network Interface and/or driver name): Aquantia AQtion AQC107 10Gbit Network Adapter
  • Line Speed (ISP): 10Gbit
  • Connection Speed (PC): 10Gbit
  • Other Internal Devices: 4 internal SATA drives, beep speaker.
  • Peripherals (USB, Thunderbolt, eSATA, etc.):
    MADCATZ R.A.T. 6+ and
    ASIX AX88772 USB2.0 to Fast Ethernet Adapter and
    Corsair Gaming K70 LUX Keyboard
  • Sound Card/Device:
    Realtek ALC1220 and
    nVIDIA TU102 - HD Audio
  • Audio Connection: Analogue RCA Pin-jack and HDMI
  • Comments (something I forgot?): …
  • OS: Windows 10 Pro 20H2
  • CPU: Ryzen 5 2400G, no overclock
  • GPU: AMD RX590 Nitro+ Anniversary Edition, Rdeon software boosts it if needed (the crash is still there without OC too), and latest driver version
  • RAM: 16Gb DDR4, 3200mhz
  • Game is on Sata SSD, running on 1440P medium/some high, capped FPS at 120
  • I close every task if I play, only steam runs in offline mode
  • Mods: yes, but the problem persists without them

Probably that helps narrowing down the problem.

Replying here to prevent topic from auto-lock. Probably a poke toooooo… @Dana !!! (:heart: )

1 Like

two possible reasons gentlemen

  • AMD CPU
  • your GPU is in fact unstable at high clocks, likely on memory side, and due to fact CE is resource intensive game it shows when running CE, try cutting it down say 500MHz for starters
2 Likes

Thanks!

Just to make things more complicated, I switched from x370 chipset to x570, from 2400G to 5700X, and from RX590 to 6700XT, and Windows boot time increased from 9-10 seconds to 28-35 MINUTES. So after a reinstall, I did not have time to fine-tune everything together, and will see if the problem is still there.

How come that AMD CPUs are suspectible to this problem?

I don’t know it is Ryzen’s fault, but it seem to plague people that use them, be it on AMD side or Funcom side

1 Like

I will poke some people from our teams that are far more knowledgeable than me and could provide insight into this error message.

As soon as I get that inforamtion I will post it here.

Thank you for your patience and understanding :blush:

3 Likes

Thank you!

@drachenfeles weird.
Seems the GPU did not crash, because when I tuned the GPU with Radeon Software, and it became unstable because of high frequency or too low voltage, the software itself crashed and restarted too, resetting to the default. When playing Conan and getting thrown out, the software ran in the background (and I tested it by leaving it open as a task).

CPU-side error could affect D3D processes? I mean even this old(ish), basic CPU handled Conan with pretty ease.

It still could be AMD problem indeed, but that is just weird that the problem usually comes up when the GPU is crashing (I did some google search, I’m far from a tech guy to pinpoint the problem), but in our case, other, demanding games don’t reproduce this issue.

I tried actually underclocking the GPU and that didn’t help. I put it back to factory settings and 4 or 5 crashes later I tried to Just limit the FPS to 60 through CE User Settings and that helped. In the past 12 or so loads it’s crashed only twice. Once at load time, and once while I was over an hour into the game sitting just outside the maelstrom not moving, waiting for it to end. So two out of 12 is much improved over the more typical 5 out of twelve - and if we discount the mid-game crash it almost feels stable - almost.

Problem here is that I really don’t want to run the game at 60fps on my 120Hz monitor. :stuck_out_tongue: The difference is very noticeable. :frowning:

So after limiting the FPS to 60 from within CE Settings the problem seems to have radically diminished! Another 15 to 20 loads from my last post above and no other errors than the two mentioned there.

This is still a game breaking bug in FC’s code though and DESPERATELY NEEDS to be fixed. I’ve counted over 10 people now being affected by this bug just in the last 11 days - mostly from reports here on these forums.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.