Fatalities not working

Platform: PlayStation 5
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvE
Map: Exiled Lands
Server Name: 3734

Bug Description:
Fatalities not working

Bug Reproduction:
I didn’t make the bug happen

Description:

I try to perform fatalities and they do not work. I have tried two different swords and axes. What I do is I get them down on their health get them in the stun mode back up a bit and push the hit button. my guy doesn’t even attack at all he does is nothing and the person falls over and dies. My friend can perform them but I cannot. this is really a bummer because I was really looking forward to this feature. Can you please help?

2 Likes

Same but there are those that are able to get it to work. I’m not sure what I’m doing wrong but if we can make it easier for the PS version that would be great.

(Of course I say that and I know…KNOW… that the minute they make that happen I’m going to do it during a Cim. Blowback event and get ganked by 7 starmetal warhammers as I complete my fatality on that one archer schlump.

I am also experiencing this problem, exactly the same as OP described it. Get an enemy down to a dazed state and then whether I left click or right click, I cannot attack. I stand there and do nothing until eventually the mob dies on their own.

Note: This is only happening on a Havoc server my friend runs. When I start a single-player game, fatalities work. When I join a different online public server, fatalities work. To make matters more confusing, my friend was also having this problem and then did something today (he doesn’t know what) that made it so now he CAN do fatalities, while I still cannot. We even teamed up and tried together. He showed me fatalities, I showed him no fatalities. I copied his game settings to see if something there was the root cause, and it didn’t fix it.

At this point, I have no clue what to do about this. I was really looking forward to performing fatalities, so it’d be nice if someone could figure out what the problem is and share it.

Thanks!

I play in Offline Singleplayer, and I have had good success getting them to work. So I found the trick is that once they enter a dazed state, ensure you are standing in front of them. Wait for 1 second, no more than 2 seconds. Then single tap Heavy Attack, i.e.- R2 button. It must be the first hit of the attack sequence, and will NOT work midway through a combo. Give that a try @FenrisdeWulf and see if it does the trick.

Best not to do it when facing multiple assailants, instead use it on the last opponent remaining or one on one.

The reply is much appreciated. Unfortunately, I have tried this multiple times. I’ve tapped both right and left mouse button, I have stepped back from the mob, I have rolled back from the mob, I have moved into position in front of them and stood still, as these have all been suggestions.

Mind you, I know how to do the fatalities. As I said, they work on a single player game, as well as on another online server I joined last night. It is only on my friend’s Havoc server that I cannot perform them.

1 Like

I think this is an online problem. When I played singleplayer on the beta, fatalities worked flawlessly every time.

Now that I am playing on official, I have gotten a grand total of two fatalities to actually work. The first time was just completely random, it worked for absolutely no apparent reason. The second time, I spam-clicked attack out of frustration and it suddenly worked, so I thought, ah-ha, now I can do them! That technique never worked again.

2 Likes

Greetings Exiles,

Thank you for sharing this!

We’ve forward this to the development team so they can investigate.

3 Likes

Thanks, Zah!

Crazy thing this evening, I hopped on my friend’s server, was busying myself building, stopped by a Dogs of the Desert camp and suddenly found that I could actually perform fatalities. I was so psyched, though had no idea why it was working now.

Played around with it for a bit, then noticed I was dying of heat stroke due to new armor I had made the previous evening that had no temp control, so I ported back to my purge base to swap into my safer armor. Decided while I was there to play with fatalities some more on the local pirates, only to discover that the ability was once again not there.

I have since experimented with swapping back to the agility armor I had worn when the ability presented itself, logged out and back in, even gone back to that village where it worked, and nothing. I had it, I lost it. I have no idea why. I changed no settings.

My friend has theorized that maybe it is a latency issue. I am genuinely stumped.

1 Like

I am playing on official 1214 PvE-C, so far no luck with fatalities. :frowning: I also tried everything mentioned above, but nothing worked.

The only thing I am doing is to leave the enemy with 1 HP left and go away. Many times they just stood in my way, making it difficult to dodge or attack/defend myself against another enemy, so in the crowd fight it gets frustrating and life threatening.

I hope it gets fixed soon in the next patch. :slight_smile:

I guess there will be the ping delay problem, similar to being unable to catch running pet cubs. If there is only for example one second to finish the deed and do the fatality, then the server lag delay can make it impossible.

I play on playstation and I have hit and miss success, but I found that I have to go up to the staggered bad guy but like one step away for it to work. I use both light and heavy attacks.

if you are too close it won’t work, if you are too far away it won’t work. There is like a hit bubble around the staggered bad guy and it is approx one step away and that’s where it seems to work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.