Foundations stuck in mesh

Pretty sure I already know the answer to this, but…

After a furious land claim battle against a troll, we were finally able to secure our new base location. Problem is that in 2 spots we have single foundations placed in the land claim that we cannot demolish. One isn’t really a problem, but one that is…

I can see the spike sticking through the wall but can’t grab it, I’ve used 1st person and tools to swing through the wall and verify that it’s alone. However when I place a wall on it and check decay it’s at 168 hours. I’m guessing that it’s inheriting the decay timer from the other stuff we have (correctly) built around it, do I need to delete everything in the vicinity to make it go down to 1 hr? Anyone know how far I need to back off the good structure?

I’ve tried fire/oil orbs to no avail (this is official PvP). I’ve repaired it (not sure how it initially got damaged since the fire/oil orbs didn’t damage it after) and waited through a handful of server resets. Staying away for a week really isn’t an option since that would mean losing the entire build as well.

Please tell me someone has a miracle fix?

If it’s showing 168 hours, then IME that means it inherited its decay timer from another block that it got snapped onto, since blocks that aren’t snapped to anything else are treated as having their own separate decay timer (unlike placeables, which will inherit time from nearby construction).

Normally, I’d think that this would be easier to resolve on a PvP since you can actually inflict building damage, but the fact that orbs aren’t working isn’t encouraging. I know in PvE we’re sometimes able to hit undermeshed purge enemies using weapons like 2-hand hammers and spears, so if it’s possible to damage block directly with weapons in PvP you might try that.

Failing that, the only other recourse might be what we PvEers usually have to resort to: kiting purge enemies in the hopes they can break it. IME, wolves are really good at breaking blocks that are low to the ground as are humans wielding 2-H hammers, Dragons and Rockslides are also good for penetrating really thick walls for blocks that are stuck in a cliff side.

Good luck!

2 Likes

If jars don´t work, then it would be best to find out to wich structure this part was connected (to know with wich parts it is sharing it´s building ID and decay timer). If you cannot remember, you could try to reduce the nearby part and watch if the timer is decreasing. As Larathiel already pointed out, the closeness of other structure pieces does not matter and for that there´s no reason to clear the vicinity. Only in the case that the block in question is sharing the building ID of your main base could you not use decay to get rid of it. Good luck!

2 Likes

If I could see the decay timer I’m pretty sure that I could demolish it as well. The only way I can see decay is by snapping another piece to it that sticks out farther. It’s definitely not connected to anything else, we’ve done the swinging a tool at the wall in first person thing to verify, it’s stand-alone, it just won’t pick up the 1 hour timer.

Tried to damage with tools, weapons, & arrows to no avail. I think jars will work because it was damaged at one point but I repaired it in hopes that the timer would go down (this worked on another clan’s stuff that was in the wall, once they repaired it picked up the 1 hour timer and crumbled).

I got over pulling my hair out and built around it with a ceiling, it looks a little sloppy but it basically got the job done. I’ve even tried getting into the mesh myself, which is not something I’ve ever done for any reason, but either my lack of experience is stopping it from working or they’ve patched the methods that I’ve found online. I’m like half a step away from contacting some of the nasty trolls that I have fought in the past to see if they could give me some pointers, lol.

Have you tried snapping a piece to it then placing bombs on that piece to try and blow both up?

1 Like

I suppose you know that it would be sufficient if it WOULD HAVE BEEN connected to other structure pieces ( to share the decay timer with those…).

1 Like

@LostInTim What @r4nd0mGamer is saying is, it doesn’t matter if no other blocks are currently connected to it now. If at some point it was accidentally snapped to another block, then even if that connecting block was later deleted, it would still share the decay timer with whatever structure it originated from.

i.e. If you build a line of foundations 100 long and then delete the 99th block, the 100th doesn’t suddenly get its own separate decay timer, but remains on the same timer as the other 98 blocks.

The only way to verify if this is the case is to snap something onto the problem block, and then leave the render distance but say in a spot where you’d be refreshing the timer of whatever base you built outward from. You’ll then have an ally in another clan inspect the problem spot. If the timer is staying topped-off, then you’ll know that it is on the same decay timer as your base. Otherwise, if the clock continues to count down on the problem pieces, then you’ll know to simply wait it out.

2 Likes

Been trying to avoid bombs, since it’s in a sensitive spot near some of the perma-structures we placed down that I don’t really want to have to tear down or constantly repair.

Ooh, I gotcha now. The foundation in question was part of a land claim spam war that occurred due to a few other foundations of the clan that previously held the spot not decaying, then I had them fix them (they were sunk in as well), but after they decayed and before I could place a disgruntled ex-employee who is currently in troll college tried to stop us from getting it, resulting in a mad dash to spam land claim. As I built the correct structure I’ve been removing the haphazard sections of land claim, but there is probably a chuck that it was attached to that I still need to clean up. Thanks, I’ll try to do that!

2 Likes

I’m having the exact same problem. I tried lots of things; nothing worked. Not even a purge or explosive jars will damage an undermeshed block.
The only practical solution would be to get yourself inside the mesh, but that doesn’t seem to be possible anymore.
I imagine an impractical solution, where, by tampering with the texture files, you somehow manage to make the terrain transparent, so you can see through it and maybe be able to target the building block. I’m not knowledgeable enough to do that, though.

We actually tried this, but we’re not able to do so. Since none of us have ever attempted it before, I’m not sure if the failure was due to our lack of knowledge or if the methods that we found online had been patched. Doing so is a bit of a mixed bag however, as success would result in the positive outcome of removing the foundation but as a whole I would much prefer that it is not possible. It’s the “mother-in-law backing off the cliff in your new convertible” conundrum.

I’m on console, so that’s not an option.

the alpha channel on the texture would make it transparent, it wouldn’t matter you still couldn’t click through, because the collision is part of the mesh object itself, the texture is just applied to the mesh.

You might try attaching something to it so you can get a good look, back off all other buildings and foundations until it’s on a different timer, then wait until it decays and try to remove the entire thing.

But I’m not sure that will work, without admin power I’m not sure how it could be removed.

Like in LostInTim’s case, this will not work, as the block was originally connected with the main base. Blocks that were once connected, always share the same timer, no matter how far apart they are.

2 Likes

Quick update in case anyone was interested, I went around removing the original land claim blocks and replacing them with land claim that is at least a bit smoother, and connected to the final building (I mean no language on earth has ever evolved the phrase “As pretty as an airport”, but at least a connected grid of reinforced stone is a little better looking than lumps of black ice going every direction).

There is one chunk of the original land claim left, which is basically a treb platform we used to bomb away some of the trolls foundations. I attached a sandstone wall to the rogue foundation and it capped at 120 hours until decay, with the base around it holding steady at 168.

The treb platform (original landclaim) shows as 168 as well, and I can’t find any other structures I missed that might have been attached and are currently showing the 120 timer. Is it possible that the rogue is getting 120 via the distance away, or is it maybe just a delay in updating and there is no connection with the treb?

I’ve definitely learned a lot more about how land claim works during this ordeal, but it seems like there is still more to know.

1 Like

Another (odd) update. So while the rogue foundation was at 120 hours, I did a few things in base and checked it again, it had changed to 130 hours. I left render (no one else was in base), and came back to find it at 140 hours. I deleted the treb platform, which was the last possible connected piece, and it went to 157 hours. It is currently all the way up to 168 hours again.

I’m hoping that server reset will correct the problem, if not I am at a complete loss.

I had three clan mates double check the foundation deletion, they were unable to find any other traces of the old land claim that could possibly exist which could have been connected to the rogue foundation.

After restart it was at 111 hours. Checked a few minutes later, it’s at 117 hours.

I give up.

I’ve found that repeatedly visiting a spot will increase its decay timer even if it lacks sufficient blocks to get there on its own.

For instance, try placing a few fish traps in a river well away from your base. When you first place them, they’re only going to have a short timer of roughly 1-hour per trap. Yet keep coming back and checking on them throughout the day, and you’ll find that their timer has increased significantly.

In otherwords, it looks like you’ve determined that the problem block isn’t connected to your base, but the fact that you keep poking at it like a pimple is only making the problem worse. :wink: Keep clear of the area and have a friend or alt account that’s not in the same clan check on it for you instead.

1 Like

That’s going to be tough since the spot is inside our main gates, but I’ll try anything at this point.

If a structure-piece has a decay-timer that approximates the full timer, it must have had a connection to other structure pieces that are still in game. I have never heared of or experienced a bug of that kind.

Let´s assume the “rogue” - part is not part of a pre-ordrered sorcery-dlc or anything like that - right?

What botheres me are the inconsistent decay timers it gives, though. I am tempted to believe that we cannot compare placeables with structures in that regard. Perhaps it is because it is under the mesh… But after rereading all the story (loved the "

"-part :nerd_face:) I tend to believe that (since you made sure there are NO other possible parts left - wich is quite a thing with several builders involved) the “rogue” may nevertheless BE a part of your actual main structure.

Anyway, if you are still interested - A procedure came to my mind how you could find out about THAT question: Build your main claim until close to the rogue and see if they are aligned in any way. You can alter the hight and “directional relevant” distances of connected building pieces, but you ONLY HAVE SIX ORIENTATIONS possible.

good luck :slight_smile:

Only one builder involved with this foundation, me, and it’s definitely not part of the main structure, as it is turned in a way that would not allow it to connect to the main structure.

OK, then. Sry i couldn´t help. But please keep us informed. I´m really curious about any news!