Game Client Launcher


#1

I downloaded the game client from the official Secret Worlds Legends page.
However, when I double click the icon, the launcher will not start. Instead I get the “Send Report to Funcom” window.
Submitted a ticket at the Secret World Legends website under account. This was on 6/27,
On 7/1 I get an email from Funcom Support asking what game this was for. I had put that in the original ticket (there’s a dropdown that makes you do that), but I replied anyway, hoping for the best.
It’s now 7/10 and I still haven’t heard back from support. What is going on???

Does anyone have a solution to the launcher issue? Or is there a better way of contacting support?

Help!


#2

Hey there - I’m sure you’ve probably tried already, but it might be worth attempting to download it again? Also, is Steam involved? I am sorry you haven’t gotten helped sooner. They’ve been busy recently with the launch of the event, I suspect. (Not an excuse, but possibly part of the reason.)

Other ideas, try running it as administrator? (Right click the icon rather than double clicking it?)

At any rate, you definitely need Funcom Tech Support, it sounds like. Hopefully one of the Moderators will see your message here and help you get some assistance. Hang in there!

Dots


#3

Do you meet the minimum requirements for the game? Also worth making an exception in your firewall for the game. Some ppl have issues with the firewall blocking it. If that doesn’t work maybe try do a reinstall?


#4

The Support Ticket Number could help so if a GM see this Post he clould easier to help


#5

Hey there soulofrage67, sorry to hear of the trouble. There are a few potential causes for issues like this, so we’ll need to troubleshoot through your email. If you can please give me the ticket reference ID I’ll be happy to check and see why you haven’t heard back.


#6

Thank you for the quick responses!
Ticket # is 1077593


#7

Thank you, I’ve DM’ed you with more information.