Golem's can equip player armor

Tried to use the bug template but it didn’t work. So here’s the jist of it.

While interacting with a Golem’s inventory, players can accidentally equip their armor to the golem. Doing so has no effect on the Golem itself, but the armor is unable to be seen in the inventory. The only way to retrieve the armor is to break the bond with the golem, or equip a different armor set, booting the previous out.

Not sure if this is an isolated problem but thought I should report.

its the same problem with the saddle in wraith horse, they dont require a saddle to ride but if you place one you cant retrieve it.

Have you tried recalling the golem? They should drop what is in their inventories when recalled and therefore should have a loot bag in the spot they were in prior to the recall.

You mean the command return or rescue in folllowers tab?


Greetings Exiles,

Thank you for bringing our attention to this! I’ve passed this information over to the rest of the team so we can investigate it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.