Invisible Enemies and mostly invisible character

Kinda hard to play a game fighting an invisible sand reaper that only has floating wings? Well i hope it gets fixed really fast since it isnt just that but many enemies only showing parts as well as structures in the game and ones you place not showing parts. Sorry but may have to call this game unplayable at most now. Hard to see a greater shale back if you just have little knobs around its face visible. Also restarting and reseting the game will not work or help at all sooooo… please fix this mess


Same boat. Decided to restart single player to check out the update and mobs are invisible. Armor invisible…Floating Head Investigation Services now open for business


Replacing your invisible with a different style could help. My long blonde character with the Wolf helmet on now has very short hair. Hopefully this will be fixed soon.

1 Like

Tomb of kalaman crocs also invisible no escape from the exiled lands

Having The same issues as stated above Invisible Armour and Mobs Making my Character is see through very frustrating. I tried crafting new armour that didn’t work and fighting human enemies that are floating heads is very odd. Also Animal Mobs missing parts like heads arms ect even being invisible at times. Also when leaving base a lot of assets are invisible for a time eg tree leave grass ect. running on a Series S

1 Like

Only vanilla armours work. I just found out you can’t even wear jewelry. Also, the Regional Specific DLC doesn’t work, either. So, my guess is, ALL DLCs don’t work.
Why some creatures and humans are invisible, is anyone’s guess. This is terrible. I cannot wear or use anything I paid for and I own 100% of all DLCs!! I’m wondering now, if the Battle Pass stuff works, I haven’t built a structure yet. I also bought the stone pieces from the bazzar. I’ll have to test those.:roll_eyes:
They didn’t test console at all. This needs a fix, NOW.:v:t3:


I also have 100% of the DLC content. Experiencing the same problems everyone else has mentioned as well as a ton of placeables not rendering properly.


I bought the Sandstone set and some of the pieces are missing. As far as the rendering, mine did that, too, but, after a few long seconds they came in. This is messed up, console should be thoroughly tested like PC.:v:t3:

Welcome to the Forum with it was under better circumstances.

Habe das gleiche problem,wie wohl alle ihr,offiziell server sowie auf privaten server auf der xbox,der fehler sollte schnellstmöglich behoben werden

I fixed my invisible dlc armour I think I was by removing the armour then open the dye menu then re equipped it then it appeared for me. Unsure if others can now see it. This was with the bear shaman set. Xbsx. Online private server (not mine)


I’m not having issues yet with armour on my own character yet, but NPC’s will be missing a chest piece, or their bodies all together. But the most concerning is spawned mobs on isle of siptah, pelicans for instance are floating eyes and a health bar. Dogs can be entirely invisible with a health bar. (I turned on health bars so I could see them) Isle of Siptah “Hyenas” are floating fur scruffs and a health bar. You get the picture I’m trying to paint here. But yet prey animals (deer, goats etc) and monstrous creatures (werewolves and the like) are all fine, maybe a little wonky textures sometimes. I can deal with the missing armor but not being able to see creatures, like a crocodile until it’s on top of me has been rather frustrating.

1 Like

I just play solo, managed to ignore slow texture loads disappearing corpses and lag still enjoyed playing pre-update. Then came 3.0 oh things have changed, I will start a new game to get handle on changes but wait i can kill an invisible croc or two try to ignore loss of emersion, not whole cave of em of course. Now I log in every now and then eat some gruel pop out of water to check if creatures have remembered how to manifest then log out again

My building pieces(some, not all)as well as placeables(ESPECIALLY animal trophies)show up invisible, or partially invisible. For example. I put up a blue awning and the cloth as never rendered, but the pole structure is there and you can hear the flapping. Others, like the cupboard, shows up fine, but will periodically disappear, BUT, still be physically there. There seems to be something wrong with the textures because, from what I’m seeing and experiencing, everything is there physically, even the DLC stuff, just not the textures. It’s also not consistent. For example, yesterday when playing co-op for the 1st time since the update, my friend could see things I couldn’t see and vis versa. He’d see a pack of crocs and I couldn’t and later while looking to mine rocks he couldn’t see them, but I could. Another thing is, when I mined the “invisible” rocks, they appeared for him. Same happened with trees, too. Sad, too he’s new to the game, and it sure as sht isn’t a good 1st impression.
Most hyenas have a greyish/black stripe from the top of the head to the middle of their back and the rest of them is translucent. I could see their body outline if in the right lighting otherwise it was a floating mohawk. Crocs are completely invisible. I use the lock-on feature and listen and spam the crap outa lock-on so I can “see” them. Looting and dismembering isn’t a problem, that’s also why I’m thinking it’s a texture issue, but, I am not an expert. I’ve learned what little I know about games and game jargon from modding Fo4. I know what textures are, but I don’t know if it’s the problem for certain, just feels that way from my understanding of textures. Although, when there are missing textures, usually it’s replaced with a purple 3d image of the thing missing, this isn’t happening.

Me too, I made the basic stone sword, she now draws it but the sword is invisible. I made the gold Red Sonja looking armor and when I put it on my character, the bottoms removed the loin cloth and showed her pubic hair and when I put the top on her nipples and a patch around her belly button disappeared. Is there any way on the Xbox to have it check for corrupt or missing files like you can do on steam/PC? I also started this new game from scratch after the patch on both Siptah and Exile lands. Also I play single player/solo play.

Yesterday, I just had 2 floating purple eyeballs screech and maul me, take my life to about 25% and proceed to chase me around.:rofl::sob:
It was actually scarier that the real thing!!:scream:
Less is more, I guess. It turns out it was a miniboss Shaleback.
The purple eyes says to me, missing textures. Something is wrong with most of the textures in the game, but the DLCs seem to have been hit the hardest.:v:t3:

Invisible enemies

**Update on the invisibleness of the update

I decided to try and put out all the Artisan tables and some were visible.
Aquilonian is invisible, and Turanian is partially invisible, the tools are there, the table is not. Argossian,Nemedian, and Khitan are fine.
09-05-22, Xbox 1 S.
I have not tried 100% all DLC items, there’s a ton. But, 5 armours from 5 different DLCs and 2 weapons were invisible. A few building pieces and many decorations.
Ok, so it seems all the alchemy decorations are visible. The table, skull, books, and vials.
Returning anything to your inventory destroys it, so you can either move it or build another. Moving has to be done in increments or it’ll be too far away and return to where you picked it up. That’s crap.

Hello there everyone!

Thank you for taking the time to reach out to us!

We are aware of this situation occurring and we have released a new patch in the meantime.

You can find the patch notes for this patch here.

Please let us know if the situation persists after patching the game.

I want to thank you for patching it, but there are still some problems. For me, at least the weapons, armour, and placeables seem to behave as intended and for the most part NPCs are back to their corporeal selves. But, there’s still things not popping in and being invisible mainly for my friend joining my game. Also, we cannot return placeables to the inventory, they immediately turn to mats, so, in essence, there’s 2 destroy buttons and no inventory button. Then there’s the matter of many placeables when put in a container, will turn into mats. It’ll be that picture that the backpack NPC uses and It’ll have a description of the item. These are the main things I could think of at the moment.