Is the Thrall Taker Journey Step Broken?

I’ve followed the Thrall Taker Journey all the way to assigning a crafter thrall to a crafting station but the final journey step doesn’t complete when I place a crafter thrall in a crafting station. Is this journey step broken or is this another case of Funcom being as transparent as tar?

I had difficulty with this step yesterday myself. However, I found that as long as I put the thrall directly into the thrall spot (just above the crafting area) the step completed. Maybe you could try this?

Thanks. I think that because thralls used to auto deposit into a crafting station it threw me.

Try taking a thrall out of a station you already have and putting it back

I swapped thralls from similar stations, because the two times you have to place a crafter, it did not recognize removing and putting back. When I used the cook on the other stove, it worked fine.

I tried taking the thrall out and putting them back in, but it didn’t work the first time. The second time I think I took them out, left the inventory menu, then re-entered and replaced them and it did. It’s as though it wants to recognize actually doing the act? Idk.

It doesn’t recognize that you took a thrall out of a station, and then put the same thrall in the same station. It has to be one that wasn’t there when you started, ie closing inventory or swapping stations between two thrall.

1 Like

Hmm… hard to nail this one down then, because while I had some issues, I got it to work after fiddling with it a bit. Idk… :thinking: edit, yeah, I closed inventory, so yeah, that’s how it worked.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.