Issue (not bug): Journey Steps with Modded Map Mod not showing in EL or Siptah properly

Game mode: [Enter game mode here: (Online official | Online private | Single-player)] Private - Server Cluster of 3 Servers (Exiled Lands, Isle of Siptah, and Savage Wilds)
Type of issue: [Enter one of the following: Crash | Bug | Performance | Misc] Performance
Server type: [Enter one of the following: PvP | PvE-Conflict | PvE] PvE (But really does not matter in this case)
Region: [Please enter your server region] USA (although that does not matter in this case either)

[Describe the bug here] Journey Steps on EL or Siptah will not show properly if you use a modded map (Savage Wilds for example that alters Journey Steps)

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Tested in Modded Server Siptah and Exiled Lands (with Savage Wilds mods in the mod list) - using Amunets Server Transfer mod where all 3 servers have the same mod list for transfers to work properly. Missing Journey steps
  2. Tested in Single Play with Exiled Lands (with only Savage Wilds and Pippi in the mod list) - Missing Journey Steps
  3. Tested in Modded Server Savage Wilds - using Amunet Server Transfer mod. - Not missing Journey steps but they are probably all SW modded Journey Steps.
  4. no other steps attempted.

The first 2 scenarios, the Journey steps were incomplete since Savage Wilds uses the same table as the other maps (MapDataTable).

It would be nice due to the ability to make modded maps, to create a special table for MapDataTables for modded maps to use so the normal maps - journey steps will work properly.

Not a huge issue (rush item) but would be nice to have modded maps not to interfere with CE standard maps journey steps when using the transfer mod. Even with the future transfer feature, to transfer quickly between servers probably best to have the same mod list or be able to transfer with a mod mismatch without crashing to desktop.

This issue would go away if server transfers will allow mod-mismatch transfers to happen smoothly.

Thank you for looking into this matter.

I believe this is a mod issue with the savage wilds map mod. I base this on the fact that WITH the map mod installed, for a server running savage wilds, the journey steps on a new single player game of Siptah and exiled lads are broken. However, without the Savage Wilds map installed, both Siptah and EL journey steps function as intended.

I have a private server running SW. I cannot play single player EL or Siptah with the SW mod installed and it does not show up properly in the mod list in order to deactivate it from within the game. it must be done from the launcher, or manually.

I haven’t tried other map mods to determine if they also cause the same issue. Have you? It could be an issue in general with the multiple map feature and the as yet unreleased server transfer feature, but it isn’t possible to test that unreleased feature yet. Using another unsupported mod to transfer between servers merely and another wrinkle to the issue.

I actually play single player on my laptop instead of my desktop as a result.


Yes, that is true. Although I run 3 servers part of a cluster and having that issue. I know its not a bug just an issue with sharing the same data table while using the same mods on all 3 servers since the transfer feature (using the mod transfer) causes the issue. I only noticed it today based on a comment from another player on the EL server.

I was hoping either, once the server transfer funcom is releasing will allow mod mismatch servers to transfer without issue or they create a new table for modded maps.

Granted, i would be happy with modmismatch server transfer more than this table fix, but I suspect that will be longer work in progress to deal with.

Thanks for your feedback. Normally, I would love to remove the extra mods from each server it does not apply but this is the only way Amunets Server Transfer works well at this time where all the mods are the exact same on all 3 servers.

I have not tried other map mods with my servers so I am unable to answer that question at this time. I was thinking of adding a 4th server one day.

If you are using AST you probably are driving a cluster with multiple maps you can play on without leaving the game.
The issue you are describing is not a bug. The journey steps are there but they are overwritten by the journey steps from other map mods you have to load in the same mod list when using AST.
Funcom did not consider the possibility of a server cluster. The way in which the datatable is used for the journeysteps does not take this option into account, but it can be changed in principle. I don’t think this is a high priority at Funcom, however.

Yes, I know. I just raising it as an issue if server transfers do not work well with mod mismatches in the future.

My hope server transfers will work smoothly from one server with one set of mods to another server with a different set of mods. Currently, that is not the case so the other way to make this all work is the data table.

Yes, i run also Savage Wild by moment in Singleplayer.
But when i go to an other save, EL or Siptah, i still remove the mod from my modlist. Seemed just a normal step to do for me. It’s a whole special map, so it may not run very fine alongside the others.

I know, for clusters, the mod need be in the list. Like you said it’s not a major problem for the gameplay itself.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.