Journey steps: Convert an Alchemist Thrall & Thrall Taker

The information you filled out should now be listed below. :point_down:

Basic Info:

Platform: =PLATFORM=
Issue Type: =ISSUE TYPE=
Game Mode: =GAME MODE=
Server Type: =SERVER TYPE=
Map: =MAP=
Server Name: Mumpitz
Mods: Pippi, Barbarian Barber, Northern Timber, Less Building Placement Restrictions, Tier 4 Followers - Mild Increased Spawn, Fashionist, Glass Constructions and more, High heels System, Dudes Delightful Decorations, No Altar Map/Light, Savage Steel vol II, Savage Steel, Seed Table Immerse RP Buildings & Placeables, Grim Production, Grim’s Wonderbody Reupload, Map Room Teleport Crystal, Age of Calamitous, CAS

Bug Description:

The journey step “Convert and Alchemist Thrall” and “Thrall taker” don’t work. We tried different types of alchemists, food, and wheel of pains, but nothing worked. It appears that the journey steps for the crafter thralls don’t work. No issues with warriors or archers. We tried it as well in the single-player mode and it didn’t work there either.

Bug Reproduction:


No, i got the same issue. I can no longer assign crafting thralls to work stations. Please fix.

this has absolutely nothing to do with the bug report from above. you should open your own bug report and give a bit more context there

Ok. I will. However, the link was: in the last step of the journey thrall taker you need to assign a crafting thrall to a station. And that does not work!

I noticed that I had to drag the thrall from my inventory to the thrall spot for that to clear. Clicking into station inventory from inventory, then from the station inventory to thrall spot didn’t clear the step.

As far as the convert an Alchemist task that is part of the Raider Journey. That is not completing no matter how I do it. I have placed all three wheels and tried all the levels of alchemists to not have this step clear. All the other steps that request to convert something, completes upon dropping the thrall into the wheel.

1 Like

I went through the mods that we share and replicated the issue with Glass constructions and more. I have posted in the mod discord of the issue and how I was able to replicate it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.