Legendary chests still lootable after hotfix

Game mode: Single-player
Type of issue: Bug
Server type: PvE

Mods?: No
Edition: Steam

Bug Description:

Before the hotfix, legendary chests had become possible to loot just by looking at them and hitting ‘F’, even if you didn’t have a skeleton key. Since the hotfix, the issue is partially resolved - you now have to have a skeleton key in your inventory, but can then loot the chest (using ‘F’) without using up the key.

I’ve confirmed this in singleplayer (Exiled Lands, no mods), but others are also reporting it on servers (see PC Update 2.5 Discussion Megathread for several examples:

Expected Behavior:

Legendary chests should require a skeleton key to open and should use up that skeleton key once opened.

Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Attempt to loot a Legendary Chest without a key using ‘E’ to open - fail
  2. Attempt to loot a Legendary Chest without a key using ‘F’ to loot all - fail
  3. Spawn a key into your inventory (or kill and harvest a boss)
  4. Look at Legendary Chest and hit ‘F’ to loot all
  5. Check inventory, you now have the legendary item and still have the skeleton key.

Looks like the hotfix partially solved the previous issue, but hasn’t quite solved all of it.


Hi @DanQuixote, thanks for creating an actual bug report for this. I saw it mentioned in a few other places. I got informed that this is noted and in the pipeline. Hopefully, fixed soon. I know I am not Funcom but you will have to take my word for it.


Sounds good to me :slight_smile: I figured with enough of us commenting on it, it was time a proper report went in so Funcom could find the info. Thanks for letting us know they’re on it :slight_smile:


Hey @DanQuixote

Thanks for reporting it. We’re aware of it and it is already being worked on for a future patch.


It still works the same for me, can loot without needing a key as I stated in my bug report put in on September 1st. Has been no change with the hotfix for me at least.

So very happy this finally got to their attention, thank you @DanQuixote nice to see it will be fixed.


If you are playing modded, yes.

NO this is on unmodded SP game which is how I test for bugs in my game.

Which version of the game? Revision #XXX

I am not able to quick loot chests without a key after the latest patch. However, the bug that is being reported here is that you need the key to quick loot the chests but the key is not consumed.

The new version my game is updated fully always as soon as its out PC Update 2.5.2 (08.09.2021). I just now tested it again and if you click on chest it tells you need a key you hit the F ( loot all ) a few times , click , click , click and the item shows up in your inventory.

BTW Narelle, I do understand what is being reported , I am saying it still is not requiring a key for me.

I will try spam clicking to see if it will work for me too.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.