Modded: missing recipes


I seem to have random recipes missing. I need to relog sometimes several times to see them and its starting to drive me nuts. So I am hoping on an off chance someone may know what mod may be responsible, or maybe its a normal game thing. Trying to save myself some time via troubleshooting by switching off certain mods. I am a little nervous about what could happen if I switch off certain ones. I think this may have been happening before I installed mods, but cant be sure.

An example of missing recipes, would be food items like spiced haunch, or even something as simple as a sandstone foundation.

Some more info…

Mods: Pickup+, Seed Table, Building Placement Restrictions Overlaps Edition, Reduced Boss HP, Litman Item Stack.
Server: Linux Debian Server, game server running under wine. Its a LAN server so only my girlfriend and I play on there. Its not open to the internet for connections.
Clients: Both windows 10

Any help or suggestions aside from removing mods would be greatly appreciated. Maybe one of the mods is known for this issue? I have tried to search in funcom and google but can’t find this issue anywhere. (did find one post by multigun to check mods from someone having this issue, but was no response after that).

Seed Table is my bet out of the options here.

Thanks for your reply. I will remove that one since it should have little impact on our base.

EDIT: First login after removing seed table seems good so far. But could be a fluke. Will monitor this over next few days, Thanks Multigun

EDIT2: Unfortunately was a fluke, still have missing recipes :confused: I guess will just have to remove mods till it works. Except the building one. My entire castle I am sure would collapse, and playing the game without it would not be fun.

If you have admin access then you can make backups of all files of your server for your experiments. I don’t think that building mod is to blame, I use it as well without such problem.

I make backups everytime i stop the server (but thanks for the advice). I have it all scripted in linux, so all good. Just a pain to work out which mod as its an intermittent issue. Good to know that the building mod seems to not be the culprit. Its my must have mod for this game. I love building and the game just wouldnt be as fun with out (not to mention needing to build a new castle).

Only 2 of us, so everything takes a lot longer than if u had a clan.

1 Like

I can’t see how any of the other mods could be a problem. Pick up plus is up to date (as always), LBPROE is mine and I know that one is fine, Reduced Boss HP doesn’t touch the necessary files in order to make recipes disappear, and litman always keeps their stuff up to date.

So if Seeds Table isn’t it, I think something else is going on. Problem is I have no idea. I’ve heard plenty of people describe missing recipes all together and never show up, and that’s always mod related. But comes and goes recipes? That’s a new one.

When I first log in on a day, most times i have missing recipes, especially via the stove. Spiced haunch is my go to food and its hardly ever there.

So I relog, sometimes I get spiced haunch, or other missing ones show up. Its rare that all recipes are there on initial login. I sometimes need to relog 2-6 times. Each time I seem to gain more and more recipes till eventually I have them all.

Maybe its a combination of mods that is the issue. I don’t know enough about how this game works under the hood to make a good call. I am a little frustrated by it, but it drives my gf insane to the point where she doesnt want to play anymore. So hard to find games we both enjoy and can play together on our home made private server.

Oh well. I can’t think of anything else to try aside from removing mods. Will remove them 1 by 1 I guess. Oh and awesome mod multigun, can’t play without it! I love the castle I have built, took me weeks just to gather enough resources…hehe

EDIT: I forgot to mention I have made several changes to the way the network behaves. I was getting a ton of lag and rubberbanding before, so I made some changes to address that. Perhaps that is the issue. Although again I am sure I had this issue before I made changes to the network.

In case this makes a difference:

On the SERVER I changed…






…\common\Conan Exiles\Engine\Config\BaseEngine.ini


I also added -LANPLAY -MULTIHOME to my start script. Without the above setting adjusted the game is unplayable when I am near our main base. Or when we enter new areas. Perhaps the game simply can’t load basses properly and so recipes aren’t loaded or something. The missing recipes happen when I put the above setting back to normal. So I know its not that.

EDIT: Have building mod + litman item stack, and still have the issue. Gonna give up now, as I have no idea what would happen if I removed Litman Item stack. Maybe if I get bored one day I will remove it and test, then if I break my server will just restore…bleh. Really thought it would be from a mod.

You could try restoring all server values to default, see if it’s still happening then.

I have done that in the past. Game was unplayable with both of us on there and still had the recipe issues. Was the very first thing I tried. The above numbers dont really make sense which is why I removed them. But I added them back in cause i was convinced they made the game better. I played around with lots of different numbers and smaller numbers didnt seem to work as well, even though the current numbers make no sense to me as a network person.

Either was we are wired LAN only, so those numbers are still well below the threshold, and my linux server barely breaks a sweat running conan exiles. Thanks a lot for the suggestion though.

Very strange there are not more people with this issue. I wonder if its due to wine…hmm

Maybe? Could you temporarily host the server off a computer with Windows on it? You can transfer save files easy enough (which based on our conversations, sounds like you already know how to do).

Yes I can, I will try that since its an easy thing. Just not sure if I can handle client + server on my windows box. Windows seems to use up a lot more resources than linux for some reason.

Even if its slow or laggy, it would determine if wine is the cause. Wish they made it work for a more recent wine. I had to downgrade my wine version to even get this to run.

If you have a high quality machine you can run it fine and play the game, especially with just 2 people. But depends on your rig.

haha, my windows pc is a few years old. I managed to get it up and running tho. I have 16gb total ram. With server and client it uses 12gb…lol. CPU seems ok, its not maxing out. After lunch I will get my gf to login too and see how it goes.

First login showed no lag or recipe issues. However it could be a fluke again and connecting to myself I would expect no lag. Real test is to play for a day off and on with both of us on at the same time. Will edit or reply with an update.

I do get steamclient64.dll popup warning (entry point not found) when I launch the server, but I just ignore them and server still seems to run ok. Can’t see why steamclient needs to run anyways, either way ignoring the error seems ok for now…lol

EDIT: Spent a day off and on using the windows server instead of linux/wine and no more missing recipes. Will test again tomorrow, but for now it certainly seems like its wine or something to do with linux. If I attempt to fix my linux version, will post if I get anywhere. However I have a feeling no one actually uses linux as a server for conan…lol

EDIT2: Upgraded wine to v4 and it seemed to run fine most of the day till now. Back to how it was on linux. I am now wondering how other people are running a linux server, if any. Not a single issue in windows. Unfortunately that is a very bad platform for a server, since updates tend to either reboot my PC without warning, or updates reset my preference for not rebooting after auto-update. Wish they had made a linux server version like all the other game servers I have ever played. Never had these kinds of issues on linux that ran native servers.

Thanks a lot multigun (and Ko6ka) for at least trying to help. I guess I have no choice but to use windows. Not sure how a VM would go, I might give that a go out of desperation. On a side note after weeks of farming black hand and various other camps for t4’s, i caved in and installed your thrall mod. Works great, still need to farm but not as painful now. I will install your level mods too soon…almost lv60…heh. I will let this thread die. Feel free to PM me or post about any fixes for linux/wine if you hear any.

I am not that familiar with linux but one day I thought I should give it a try. So I found and stored this reference for future:
I don’t know, may be it’s trivial for you but I’ll just leave it here.

That is the guide I checked out when I first tried to setup my server. I don’t use any of the screen stuff and other bits and pieces for headless systems. My linux box is my main PC, so its a desktop/server. I have a KVM switch that lets me switch between my windows and linux box by pressing a button. I have a dedicated steam account on there I use for all game servers. Last game was ark, worked great on there.

Main point about that guide and possibly every conan exiles linux server out there, is that they are most likely ubuntu. Where as I use debian. Main difference being that Debian runs much older software/drivers than ubuntu (and more time between major updates). To use anything “new” or cutting edge requires a little more work for debian. Never had any issues in about the last 10 years of using debian for game servers till now. But this isn’t native linux game server software, its “wine”. Wine is kind of like a windows emulator or virtual environment that can be run through the command line for windows apps.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.