No Servers to connect on PC

Game mode: Online Official
Type of issue: No servers to connect to
Server type: Any/all
Region: USA

There are no servers to connect to. I haven’t played in about… 6 months or so and had the game uninstalled. I downloaded it today, hopped on, and there are no servers in the online portion. I can play single player, even continuing where I left off last time. But no matter how long I wait, no servers pop up. Filter is set to “internet”, I have tried multiple other settings for combat mode, community, region, etc, including just leaving them all at “any”.

-I looked up port forwarded and opened the specified ports. No fix.
-I have tried to get to the servers through steam. With this, I can see the server list. When I go to connect I get a “failed to connect to the server” error.
-I have tried running Steam in admin
-I have tried the command prompt in a stickied post
-I have tried reinstalling the game
-I have tried with battle eye on and off

Any help? What am I missing?

Hi Jekrath, sorry you’re having trouble. I’m just another player, and I’ve simulated this issue on a test computer. At Steam, please click View | Servers. It will load on the Internet tab. Allow the list to populate. Choose one, right-click it and select “Add server to favorites.” Load Conan Exiles, and select Play Online from the main menu. In the Filter drop-down choose “Favorites.” If the server you favorited earlier is there, you have a workaround for now. Feedback and we’ll find a solution for your unfiltered list-loading.

The only time I ever experience this issue is when a new patch has been deployed to all the servers and my PC has yet to update. In such instances, I can mark the “show invalid servers” option and they all start showing up.

If you see the same, then try doing a verify files in the game’s properties from your Steam library.

Thanks for the response. I tried this out and made a few servers “favorite” in steam. They still will not populate in the server browser in game.

Two things of note. Last night, after I posted this, I was able to get one server to show up on the server list. It was a private, locked server, with no population.

Second, I’ve noticed on the Steam Server area, when I click on a server, click view server information, every server I check shows “server is not responding” in the lower box under Player Name/Score/Time. Since I have never used this way to connect to any games, I am not sure if this is just a normal thing or not.

I have tried this and verify the files in the steam library. No change. Thanks for responding.

1 Like

Hmm, this makes me wonder if it’s a firewall issue. I’d check to see if there still an exemption in Windows firewall and also your antivirus.

I have tried with my firewall completely off, just to see. Nothing changed. I will look into the anti virus issue.

I have finally found a work around. I tried direct connecting and eventually made it into a server. The first I tried was a custom with mods. I had to DL the mods before I could “connect”. However, when I hit connect, nothing happens. 2nd server (one a friend was playing on) said my ping was too high for the server. Third server, an official PvE server, I was able to direct connect and get to character creation.

1 Like

I have been able to get the work around by direct connecting. Not ideal, but it works for anyone else having this issue.


Well done. I’ll add this thread to my reference list, and with any luck when he arrives at work on Monday @Ignasi will offer a full solution for you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.