Not able to finish First thrall journey.(unlocks Purple Lotus Gas)

Game version: Playstation 4 , Age of war chapter 2 v1.95
Type of issue: Bug

Bug Description:

I have placed level 4 crafters, 4 smithers and many tanners and alchemist, I’m still unable to finish off the journey. I have crafted items with them i have closed the game and restarted the server, the only way i believe i can unlock it is by unlocking all recipes but kind of defeats the purpose of the game. I have since leveled up to 56, It have to do with not having something they can craft that i cant but for some armors they can craft where i cant. I’m stuck here help is appreciated.

Crash: NO crashes for the game.

For crash reports please make sure you add as much inforamtion as possible. Also add any crash logs you might have. The support team will also follow up on the issue and they might request additional inforamtion in order to properly address this issue.

Steps to Reproduce: N/A

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

Step 1
Step 2
Step 3

Greetings JimmyCharts!
Thank you for reaching out to us and welcome to our forums!

In order for us to properly assist you could you please tell us exactly which step of that journey are you struggling with?
Additionally, in which server are you playing?

We’ll be waiting for your reply!

It sounds like you’re stuck on the “place a crafter on a bench” step. You have to click on them while they’re in your inventory and manually place them in the thrall slot on the bench.

The bench should be of the lowest level, not upgraded.

Hello Saint,

sorry for the delayed response life you know… the step is the final one(Assign a crafting thrall to a station) its not completing it for some reason. I have tried 2 named crafting thralls making shaed wood no luck, 4 named armorers no luck, no luck.

Im playing on a single player server.

yeah i have them in the top thrall box. Like the active box.

I have tried no luck :confused:

just tried again with a Cimmerian carpenter one making split wood and it didn’t work. on a lvl one carpenters table.

Was your carpenter freshly tamed? You need to place exactly the artisan that you got when completing the previous step of the journey. At least that’s how it worked for me a few days ago.

Hello Teng,

I believe it was a carpenter two but it didn’t work i can try again with the lowest tiers crafting table again, i just hope i didn’t drop him, I’m up to level 60 now and have been to sepa and have a few named crafters lol. Should post again after 8 est.


In general, the travel system is very capricious. I remember on some trip I needed to mine iron ore. I hit the knots with a pickaxe - there is no step. Until I read in the description of this step that you need to hit with the left mouse button. And I’m used to hitting with my right button.
So the game may not give you a step with another artisan.
Purple Lotus Potion is a useful item. Not because, that someone is afraid or does not know how to crush the fleeing inhabitants of Sepermeru. Simply because, having knocked out an artisan and then got involved in a battle, at the end of it you can suddenly discover that the knocked out thrall during this time fell under the net and disappeared.
So - good luck! :wink:

The issue can be solved rather easily: Instead of pressing R1 to transfer the thrall to a workbench (he would wind up in the workbench’s inventory) press X on the thrall, then move the highlight to the slot for the thrall and press X again.
The thrall is placed there without any detour, and the last step unlocks as it is supposed to.

Looks like the expected behavior of R1 has been lost in one of the previous updates. Could it be that the event handler for pressing R1 has been messed up so that the transfer isn’t initiated correctly any more?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.