Orb of Nergal Broken

Game mode: *Online private |
Type of issue: *Bug |
Server type: * PvP
Region: North America NE Canada Central
Hardware: [PS4 Slim

Bug Description:

When Accessing The orb of nergal bench the menu comes up but you can not select or exit the bench. You are unable to make any changes and a Hard close is required to leave the workbench

Expected Behavior:

You should be able to access the menu choices and close the workbench.

Steps to Reproduce:

Access the orb of Nergal


Yep, this exact thing happened to me on single player. Went looking for this thread

1 Like

Same in AU. Can rotate cam but nothing else. Only thing i can do is restart game.


For sure is a problem that can be solved in a very short time. On PC it would be patched in no time, hopefully for a quick hotfix

1 Like

I confirm that it does not work. You cannot select anything, cannot exit, you can only rotate the character around. I had to hard reset.

…good thing the game does not save while you are in there XD

Single player here.

Same issue.

I’m having this issue aswell…50 gb extra and the game is more broken than fixed now.

i confirm also

Greetings Exiles,

We’ve passed all this information over to the rest of the team for further investigation.

Thank you for your patience and understanding while we look into this.


Seeing as it’s a minor problem, can we hope for a quick hotfix without having to wait months for the next big update?

I doubt so. We’ve been waiting for nudity fix for 5 months…


Yes, but the admin panel and this here are things that can be fixed quickly. Precisely because we have waited months for other bugs, I think it is their duty this time to provide hotfixes, at least for these things that can be fixed immediately

Same on XBox

Just don’t hit randomize by accident…only button that works :joy::cry: stuck looking like a rocknose for a while now

1 Like

I was sure the square was the only thing that worked so I swore to myself not to press it. Who knows how many unfortunate people no longer recognize themselves in the mirror :rofl::rofl:


1 Like

The real problem for me is we use it for Roleplaying uses like Haircuts, or make up changes. Im stuck bald after my character had a mishap with hairdye and an alchemist. The intent was to grow it back slowly along with his Zingaran mustache

1 Like

Same, even tho I’m solo i roleplay hard haha, like adding a tan to my nordheimer when he’s lived out in the desert to long, just wish they they would fix the original beards so they don’t look so patchy

I have experienced this error, too. I started a new game after the 1.70 patch so I believe the game is clean. This is the only bug I’ve seen so far.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.