RenderThread timeout after 60 seconds

Game mode: [Enter game mode here: Single-player
Type of issue: [Enter one of the following: Crash
Server type: [Enter one of the following: PvE
Region: UK

[File:C:UE4\CSAND\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 959]
GameThread timed out waiting for RenderThread after 60.00 secs]

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:
1.Start game, and get to start screen
2. Choose single player, then Continue
3.Note that this also occurs when choosing Mods option. Worked here earlier, when I went to remove all mods, but after then next crash and reboot get the render timeout issue when choosing mods.
4. PC itself crashes with an error driver_power_state_failure

Tried verifying files and this completed succesfully. Also set graphics to low end laptop mode.
Nvidia gtx 1070
Intel i7 7700
16gb ram

1 Like

Hey @Owslebury

Are you using any mods?

Not any more. As mentioned I was, but after removing them all in the mods screen then game crashed as usual. When I went back in again, and chose the Mods option, to try and add them in 1 by one, so as to test the supposition it’s a mod causing the issue, the crash happens now just choosing mods.

Also to mention, when this was happening yesterday I actually was able to start a New game, playfor some time, build a complex base. Then I got the error this morning loading up that save while at this complex base. This happened before also on my previous character, same pattern, crash seems to happen when trying to load a complex base.

Edit: just tried again and started new game without issue with mods. Restarted game entirely, continue without error. So, looks like need to keep it simple, and not try to render complex base.

Can be different things, and mods you use, a corrupted DB, or else.

At first, did you run a game-file verification trough steam ?
Then, what are your specs ? Make sure your pc can handle the settings you ask him to run, and make sure there isn’t any overheating isssue going on.
You describe that issue still happens after a while you play, and with complex bases. So this seems bit related.

First like said, i would test files. Then run a new test game, without any mods. Spawn some stuff you need, build, test, run around, see what happens.

Hi, yep specs in op, and also verified files. Have had the game for months with no probs (and same mods) but only simple 2x2 house complexity. Then built a complex of hundreds of foundation size plus building several levels and pow, bsod. As mentioned, have already seen this twice on 2 diff new games.

Ok, created a new char last night and left in front of the starting stone. No mods. Started up this morning and continued. Crashed. Guess I’l try reinstalling next.

Verification of game files by Steam is mostly a good thing to try at very first.

Hi, i might help here. Do you use Geforce experience?

1 Like

Jumping on here because I’ve been having exactly the same issue. Good specs, ran cleanly until the last couple updates. The render thread would happen a couple of times, but I could restart, no problem. Now it’s happening every time I load the game - sometimes at the main menu often during the loading screens, and if the game gets loaded, it hangs after 5 seconds in the world. After a fresh installation I was able to create a character. I laid down a fiber bedroll at the shattered bridge and logged out. Nada.

I have:
-Unsubscribed from the one mod I had
-Deleted the workshop folder in steamapps
-Reinstalled the game
-Uninstalled Geforce Experience
-Run a clean install of my drivers
-Installed legacy drivers from last year
-Verified the game files in steam after every crash.

250 hours into the game and now it’s unplayable. I feel for you Owslebury! Googling brought me here and I registered to add my voice to your issue. I hope we or Funcom can find a fix, because I love this game.

1 Like

Trip report:

I tried:
-Windowed mode
-Capping framerate at 120
-Changing graphics settings to low-end laptop mode.

Same result! Hangs after 5 seconds in-world.

1 Like

Hey @Wayfaring_Stranger

Thanks for adding some additional information for this issue and sorry for the frustration this problem is causing for you.
We’ve sent your feedback along with the original report to our team.

1 Like

Thank you Ignasis!

Interestingly, the common denominator appears to be our graphics card. I have the Geforce GTX 1070 as well!

I look forward to hearing the outcome from the team.

1 Like

Looks there are some issue around GeForce.

I would search on this side for your own issue.
Like you said, specs seems ok, so may be that. I don’t have GeForce experience, don’t like it for divers reasons. So can’t tell you, but have read here and there different posts about that.

I’ve had this happen quite a bit in the past - make sure your gpu drivers are up to date. Though - admittedly - when I’d get these RenderThread timeouts it was usually after the game had updated and there was a driver update put out in the days prior.

1 Like

I have been having this exact error for months. Tried every driver, removed all mods, crashes in SP or server, with mods or without. I run a 1080Ti.

Had another thread about it but it got closed due to me working away and not being able to reply.

Ignasis has been replying back and forth with me, still no definitive answer from the devs as far as i know. this is really frustrating. I haven’t been able to admin on our private server for months.

I do not use GFE.

1 Like

Yeah it started happening during the penultimate patch, but it’s been completely broken since the trebuchet turning patch!

I’m not familiar with the time line of the patches, though I believe the trebuchet patch was very recent… When did the penultimate patch drop? As I said, I have been dealing with this exact crash for months… my first crash log was generated on 8/1/2018. Have submitted one every crash.


That sucks - I didn’t start periodically crashing until mid-January(?) but it increased in frequency from the 05/03/19 (or thereabouts) patch and with the turning trebuchets has become completely unplayable. @Tiny_Montana You clearly have been suffering long before I have! I saw your original post but it was too late I think to add to it. I’m glad we can keep this one active until the devs get back to us.

I had hope that the building optimisation fix would have done something, but I can’t even select a solo game, I get the RenderThread timeout at the DLC store page popup now!


Hey everybody,

Our team is looking into this crash issue. We apologize for the frustration these crashes might cause and we appreciate your patience while we’re working on it.

1 Like