Savoury Feast not giving concussion bonus

Platform: PlayStation 5 (Digital Edition)
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvE
Map: Exiled Lands

Bug Description:

Savory feast not providing listed bonus.

1 Like

I wonder if this is intended? Since Age of War Chapter 2 was released, everything I use my steel truncheon on goes down with one hit. At that point, a concussion bonus does not really matter.

Of course, knocking out thralls being so easy now might be just another bug for all I know.

That may be a glitch. Im not taking things down that fast, and ive added all bonuses, too.

That’s a bit vague, can you elaborate a bit?
The food seems to be working fine for me on PC and in the devkit

It feeds you, but doesnt privide the listed concussion bonus.

How are you confirming this and what are the details of your character.

For example you can only ever have a single food buff and a single elixir buff and if you have weapons / armor applying similar buffs that would conflict and overwrite them.

Creative mode doesn’t show buffs at all so make sure you’re not in that

And lastly sometimes the icons don’t show up on servers, however the effect itself would still apply which sadly on consoles you can only test by knocking things out and counting the hits.

I did check the code for it though and it still applies the actual bonus and I also tested it in single player in the actual game and it works fine

I also tried it on a dedicated server too :slight_smile:

So, I guess the question here is whether this is just an instance where the buff UI widget doesn’t show up, which might happen sometimes, but the effect would still apply, or whether the Playstation somehow has a slightly different version.

Have you tried a different food buff immediately after this one didn’t show to see if that would? or multiple of these?

I didnt try that, but i did try signing off and on again, and it still didnt work. However, today, it worked fine.


I do see feasts fail to provide the usual buffs… still.

Workaround: go to a respawn point–bed or bedroll–and remove bracelet. You will respawn. Grab your stuff off your corpse. Try the feast again.

I’ve seen it work–just today, in fact–but I guarantee nothing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.