Stuck on an Infinite Loading Screen when joining Private Modded Server

Basic Info:

Platform: Steam
Issue Type: Other
Game Mode: Online Private
Server Type: PvE
Map: Exiled Lands
Server Name: The Boi Z
Mods: Pippi, ModControlPanel, Thrall Wars, Savage Steel, Warrior Mutator, The Darkwoods, Emberlight, Glas Constructs & more, Fashionist v4.5.4, Better Thralls, Improved Quality of Life 3.4.9, Less Building Placement Restrictions.

Bug Description:

Hello! I’ve tried looking everywhere for a solution to this but I couldn’t find any. I rented a server to play on with my friends, and they were able to connect- no problem. But when I tried and joined the server I was stuck on the loading screen the bar would load up to 100% but never actually progress past that until the server timed out, sending me back to the main menu. I’ve tried every single fix I’ve seen online but nothing seemed to help. I can not get past this loading screen, and I thought alright as long as it’s just me. But it then started happening to my players and one after another we all got the same loading screen bug. Which is honestly so frustrating.

Bug Reproduction:

I join my private modded Server, and that’s it. After clicking join I’m stuck at an infinite loading screen until my connection times out, on fresh game instal it works a little but inevetibly repeats at seemingly random intervals.

Edit: I have no clue why my bug report was moved to the Server ads, I’m not trying to get players I’m tryna get help. xD

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.