Summoning gods in single player not working

The information you filled out should now be listed below. :point_down:
Please copy this info and paste it into a new report. Thank you!

Basic Info:

Platform: Xbox Series S
Issue Type: Gameplay
Game Mode: Single Player
Server Type: PvP
Map: Exiled Lands
Server Name: =SERVER NAME=

Bug Description:

I am on single player admin mode enabled just wanted to test out the gods so I have myself the tokens needed though admin control but when I use the token my character just stands there the animation to summon happens but that is all then I get a loading screen after about 2 mins and I’m back to where I was standing there but the token has been used and no god

Bug Reproduction:

When I’m trying to summon the gods in single player nothing happens

It might be an Xbox issue. I did a summons not but two days ago in single player (testing it out like you did) and it worked fine. Takes forever, but it did do everything it was supposed to. I’m on PC though, so, like I said, it might be an Xbox issue.

Hope that piece if information might help the Devs figure out what’s going on and get it fixed for you soon.

Yea I’ve tried everything so far with every god token and all my guy does is stand there waving his arms for about 2 mins then game loads me back to normal I was wanting to test as I’m on a pvp server and wanted to use a god on a base and thought I’d test it first in single player! Glad I did cause if it didn’t work in a official server after saving up the zeals then :face_with_symbols_over_mouth:

Yeah on Xbox it can do this but I found that in single player many places don’t allow god summons just be sure you are near no land mark or ai camp try el in desert that’s what I did but there should be a prom if failed and check your logs to see if it’s tjere