Official Server: Unable to Summon God Avatar

Game mode: Online official
Type of issue: Bug
Server type: PvP
Region: North America

The bug is that I’m unable to use the “True Name of Ymir” avatar token. Everytime i try to summon this god it gives me an error saying “Can’t Summon Here”. I ran completely around the area and everywhere it is telling me this. Im not by any structures and my character is not blocked.

The server shows Avatars are enabled, so it shouldnt be due to that. I have 48 hours before this token disappears and its kinda annoying i can’t even use it. Considering our T3 altar was destroyed and legendary thrall was used while making it.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Try to summon “True Name of Ymir”. Gives error: Can’t Summon Here.

Hey @ArthiumX

On which server is this happening?

you can always attempt to replicate is single player mode. Teleport there and spawn in the coin to try and test if you get a different result. Perhaps that helps you solve the difference if you can summon in single player in same spot

Hey! Thanks for responding. This is happening on Official PvP Server #1944.

Is there area restrictions on where you can summon certain gods?

That is a good idea. Whenever i get home, i suppose i can test that out.

1 Like

Just tested on singleplayer. I am able to summon the “True Name of Ymir” Avatar in the location I was at. So this seems to be an issue with the Official Server or something else related to multiplayer i guess.

Hopefully I can hear something back soon! Thanks for the tip on testing it out. @Ranson

1 Like

Hey @ArthiumX

We’ve corrected the setting and triggered a server restart. Could you let us know if you can finally summon your avatar during today’s raid time?


single player is a good resource to use sometimes, welcome :blush:

I would’ve loved to be able to test this.

However, since we are going to be out this evening past when the god token was going to expire, we summoned it in a northern area on the map last night. Kinda a bummer since we wanted to use it on a certain clan. But we also didn’t want to waste it.

If you could have someone from your team get on to test it, that would be great because its going to take us a while to gather the resources back up to summon a new Avatar.

Thank you for updating the settings and doing a server restart though!

You were probably too close to there land claim to summon …

I wasnt. I was pretty far away while testing it. No place would allow me to summon. Heck, the actual base that we did summon on i was way closer than at the other base we tried to summon on.

I wonder if they were cheating and have structures under the terrain tiles. In the mesh. Not sure, but i probably wont be testing that out again anytime soon! ha.

or it could be that whatever settings update the team did on server #1944 unbugged the avatar token. :man_shrugging:

I don’t think land claim matters, or has that changed? I have multiple times stolen an arch priest inside of someones base and summoned while on top of that enemies base. This was pre-1 hour craft time though.

Actually come to think of it my friend summoned set on an enemy base the other day … I will have to double check but I think he could have used there shrine too make it and that was why he could summon it .I know last time I went to summon it would not let me anywhere near there base … I had to put a foundation amongst the enemy’s landclaim and stand on that … I will have to see if we have 500 zeal’s spare and re-test ( t3 set shrines come back after server restart :sweat:)

1 Like

and yog

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.