Avatars on Official Server Post July 1st 2020 News don't work on Mitra, Set and Yog

Game mode: Online Official
Type of issue: Bug
Server type: PVE
Region: Asia


I am playing in server #1325.
It was announced on July 1st 2020 that Avatar is back in official server. I’d like to report that only 3 altars have the option to summon avatars i.e. Ymir, Jhebbal Sag and Derketo. The other 3 religion altars don’t have the option to summon avatar i.e. Mitra, Set and Yog. All my altars are T3 with T4 priest assigned to them.

Please look into it.

Cheers!


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Log in
  2. Open T3 Mitra, Yog and Set altar



3 Likes

Good well written report, Snug, along with the appropriate screenshots. /tiphat.

With that, I feel certain it will get attention.

Regards

jim

Can you check whether they are even enabled on your server? Esc - Settings - Server Settings - Combat:

The newer religions had the tokens visible even though the gods were disabled, you could craft them but not summon the god. The older ones had the tokens hidden. If the gods are disabled, you won’t see the tokens as reported by you here.

Can confirm this for official PVP server, even with 500 zeal inside.

Same on all servers official I’ve tested many

They didn’t remove the setting in server settings

1 Like

Well this is unexpected (I guess that’s why they call it a bug). When they gave us the chance to use them on Testlive, I had a Mitra shrine with a T3 priest, and was able to create the token and summon the avatar. I just went to refresh my maprooms on the Testlive server and checked my Yog altar while I was there.


Please note this screencap was taken from the Testlive version of the game.

1 Like

None of the gods can be summon after the July 2nd patch, you can craft the token but as soon as you summon, you will get the message that gods are disable. Token now expires at 6 hours. Official servers. @Ignasis

1 Like

@Narelle, It is disablled. But, unfortunately we couldn’t change server setting in official servers. All official servers settings are dictated by Funcom team.

@Iorail, i checked the setting and seems like the Avatar is still disabled in official server, at least mine in 1325. See screenshot. Attention for @Ignasis

1 Like

Right, but according to the 01 July announcement, it shouldn’t be that way. They should be enabled right now.

Like my friend before me said, they should have been enable after July 2nd update, according to the official announcement, but either they forgot to do it or postponed it and forgot to tell the player base.

:woman_facepalming:t2: Funcom…
So much time in preparation for the rework of Avatars with minor changes for balancing and even though it failed like a nonstarter. This meant to be a big thing which needed time and now they don’t even respond th this. Sorry but this is a 10 out of 10 fail :face_with_symbols_over_mouth:

Hello, our team is currently looking into this matter, apologies for the frustration caused.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.