The 3rd Age bug can't pick up the map

Hello,

I am trying to do the “The 3rd Age” investigation mission. I picked up the artifact (Strange metal clockwork) it is in my inventory. I quit the game and when I return, it is still in my inventory but I am not able to pick up the map (next part) because even if I tried to pick the artifact again a message told me that I already have that item in my inventory. BUT, the quest does not advance to the next part where I must pick up the map. I tried to pause it. I tried to delete the quest item, I can’t deleted it, the game does not allowed it. I even tried to pick up another investigation mission. I am stuck with an incomplete quest.

You’ll probably need to put in an in-game ticket for that problem.

Odd behaviour that you are seeing, I just tested logging off after picking up the key and before picking up the map and couldn’t get it to bug out.

What does the quest text say to do next? Is it

image
Or
image Or something different?

As Pinkhair notes, it may be that you need to raise an in-game petition for help from a GM with /petition

1 Like

I will contact a GM but for your information I am at the tier 1 part. But, I already have the artifact.

Well, /pétition (I am in a french version) did not work at all. The chat window for a petition opened but I can’t write anything in it…I will try the e-mail…

For the in game petitions, you need to select from a list of categories and look at the ‘common issues’ before they allow you to actually type anything.

1 Like