Thralls don't autoequip weapons

Game mode: Online official
Type of issue: Bug
Server type: PvE
Region: LATAM
Mods?: No
Edition: Steam

Bug Description:

I started a new game on Siptah map. So I didn’t have any thrall yet and I decided to rescue some thrall from a jail. First, I rescued a T1 bearer (I know, one of the worst options to use as follower, but that’s what I got). When I opened his inventory he had 3 items, a weapon (a maze) and two bags named “XX_Unarmed Right” and "XX_Unarmed Left. So, I took those bags (I think they are not supposed to be there) and threw them to the floor. Now, the problem is that everytime he attacks, he uses his punchs. He never self equip his weapon, I have to put it in his hand, and if there’s no enemies around, he unequip it very fast after 2 or 3 seconds. So, everytime I have a fight, I have to equip it in his hand when the enemy is trying to kill me, and my thrall punching (sometimes doesn’t even take the weapon when I give it to him manually). I thought, okay, maybe this thrall is bugged, I tried all combat options, and I also tried the command “rescue” from the thralls panel and nothing worked.

Later, I got my second thrall, also from a jail, this time a T1 Fighter, same problem, he had a sword and two bags. So I didn’t throw the bags, just to try if it was the problem. But nothing, same bug, he attacks with his punchs, and never self equip the weapon. I tried to give him another weapon, but nothing works.

It’s not enjoyable to play like this, I hope you can fix it. I didn’t have this problem last time I played in Exiles Land map, just now that I started a new game in Siptah, and it was with the two thralls that I rescued from jails.

Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Rescue a thrall from a jail
  2. Order him to attack
  3. He doesn’t auto equip weapon (use his fists)

I’m playing on Official Server 6307 by the way, no mods.


Hey @elendil093

Thanks for the observation. We’ve informed our team and they will look into it.


Thank you. Finally they started to work normally, I didn’t do anything, just came to play another day and they were working normally. But lately I’m seeing a lot this problem with different enemies, they attack with their fists. For example, the boss in the King’s Niche (10B in Exiles Lands map) is ALWAYS 100% bugged, you go there and he attacks with his fists, and sometimes make combos like if he has an invisible sword, but he could hit you all day and you don’t get any damage. It’s a good way to farm legendary weapons and lot of gold and silver coins if you don’t fix it… but I would prefer it works fine.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.