Unnecessary shepherding and / or hand holding

This is unnecessary.
I don’t need it or want it.
All it’s doing is clogging up my screen.
I want to be able to disable it.

untick Settings–>Gameplay–>“show journey steps”

When I relog, I have to do it again as it doesn’t seem to save state right now.


You can also just not select a journey after you get done with the first one.

1 Like
  1. I have journey steps unchecked.

a. Even with it unchecked a window still shows up urging me to select one.

  1. I simply don’t want that showing up in my window.
    It’s a distraction and I don’t need it.

Should I add this to my “review” of all game breaking bugs @Vahlok

But the previous one that was always up in the corner listing 3 journey steps to complete, didn’t bother you?
If there is an option to turn it off it really aught to remember it and not have to reset every time you log in.

So where is the rest of the thread “Unnecessary shepherding and / or hand holding”, seems the body has little to do with the title.

I appreciate your feedback on this.
Today when I logged in, I noticed it was no longer showing up in the top right corner as it did before.
I guess all it took was to log out as you mentioned.
Forgive my doubt.

I take that back.
Take a look at this persistent pest
I log back in just a few moments ago, and sure as hell, it came back … ignoring my settings.

Needless to say, it’s back.

I wouldn’t call it a game breaking bug.
It was just an annoyance and it required a relog to expedite the “fix”. … (which really didn’t fix a damned thing)
(It was an oddity since “Show Journey Steps” had been unchecked prior to this happening).
But it is an annoying as hell bug.

Some people prefer to have a “guided tour” of their game.
I for one don’t need it.
I was around long before journey steps were added to this game and when they were introduced, I was able to “turn that off”.
I’m sure you’ve seen videos and screen caps where journey steps showed up mostly in the bottom right corner of their screens. There’s no mistaking it.

This post was about a way to disable the current “Journey” steps display that still show up where (for me at least) they’re not wanted and should not even show up.
With this Chapter 3 update, the journey steps were revamped but currently leaves no option to disable it even when it’s already been disabled in the settings.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.