War-torn Rhino didn't fix in 2.0.3 hot fix

I have isle of siptah

but War-torn rhino is locked

Hotfix failed to fix my problem!

Am I the only one suffering from this problem?


Hey @kirinbeer

Welcome to our community.
Make sure you have the War-Torn Rhino DLC enabled when starting the game. You can do so by going to the DLC manager on Steam and making sure this checkbox is enabled:

1 Like

this is not able

i purchased all dlc but only 12 dlc unlocked

why ?!

What package did you buy (Siptah DLC or complete edition) and which region is your Steam store set as?

steam is South korea and Complete edition

What wher its that list? Never sean that and cant find it!

1 Like

Thanks, steam in what it is not the best and clerast working platform. Always mess stuff up.

Thanks for the information. We’ve contacted our store coordinator to see if there is any misconfiguration with this DLC package.


I hope my problem will be solved soon.

One Year Later and the Problem is not fixed? I pre Ordered Siptah in March but the War Rihno not showed in the dlc list.

Uh, 8 months is not a year. And it was fine for those 8 months until very recently. It’s not a “it’s still not fixed thing”. It’s a very recent broken thing.

1 Like

8 Month/ 1 year. I buyed the game in March and since then i have not the pre order dlc in the list. So it CAN’T run 8 Months. Maybe 5 but not 8. Ok then i will change my post… 3 Month and no fix. No way to contact the support. Very nice

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.